No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

BuscarV aplicado

20/38
Recursos

Aportes 210

Preguntas 13

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad?

En caso de que quieran agregar alguna nota cuando el dato buscado no esta dentro de la tabla, lo pueden hacer as铆:

=SI.ERROR(BUSCARV(Q15,B14:N113,2,0),鈥NO ESTA EN LA BASE DE DATOS鈥)

Mi f贸rmula
=BUSCARV(B14,Tabla17.2,12,0)

B14 - El valor que estamos buscando
Tabla17.2 - Al rango B4:N103 de la hoja 鈥楥lase 17.2鈥 le puse este nombre (ese tema se ve en videos anteriores), esto hace que sea m谩s f谩cil de escribir y leer la f贸rmula
12 - Es la columna que quiero que devuelva la f贸rmula
0 - Es lo mismo que escribir FALSO, es para que se use una coincidencia exacta

Si se utiliza BUSCARX en vez de BUSCARV no es necesario que la coincidencia del valor buscado este en la primera columna a la izquierda de la matriz.

En excel ingles es VLOOKUP

Es importante no olvidar fijar las celdas de la matriz.

me encant贸 el SI.ERROR. Mucho m谩s est茅tico y sirve para reunir todas aquellas celdas an贸malas, para revisarlas y arreglar el problema que tengan.

ESTA CLASE FUE GENIAL , PERO ES MEJOR USAR LAS LISTAS DESPLEGABLES CON LOS NOMBRES

Usar NOMBRAR RANGO DEBES, te da mas tiempo para ver mas memes V:

Y no te olvides de fijar la matriz.

si no quieren escribir falso pueden colocar "0" que dar谩 el mismo resultado

En el caso de la celda que contiene el nombre, utilice una lista desplegable para que as铆 el usuario que desee saber el valor de la expectativa de inversi贸n y la inversi贸n real 2018 pueda localizar f谩cilmente los nombres de las personas

Una manera de hacerlo m谩s din谩mico y evitamos errores en crear una lista desplegable con el nombre de los asistentes.

No necesitas contar antes de introducir la formula, cuando seleccionas la matriz a buscar te aparece los numeros de columnas que tiene

IMPORTANTE鈥> El valor buscado debe estar en la primera columna de la matriz
2) Antes de hacer la funcion 鈥渂uscarV鈥, mirar en qu茅 columna est谩 el valor que necesito asignar.

ESTE CURSO DEBERIA DE SER EL DE EXCEL B脕SICO Y NO AN脕LISIS DE DATOS. ES LA REPETICI脫N DEL B脕SICO.

cual es la tecla rapida para fijar 鈥$鈥 ??? que veo que solo le das una tecla y se colocan todos automatico!

Al principio me costaba trabajo detectar el error, hacia la formulas miles de veces desde 0 para ver en que fallaba

Gracias

Pr谩ctica Clase: ![](https://static.platzi.com/media/user_upload/image-c9b32dcb-dd85-40c0-83fa-f590eea46c86.jpg)
![](https://static.platzi.com/media/user_upload/image-a0518de5-b99a-4cd5-b19a-c13d1852bda9.jpg)![](https://static.platzi.com/media/user_upload/image-6e286a2b-1434-45d6-a047-2c55c0cecb81.jpg)
Es importante tener en cuenta que buscarV s贸lo me permite buscar valores hacia adelante y buscarx me permite hacerlo hacia cualquier direcci贸n

otra forma de complementar el BuscarV Aplicado, es combin谩ndolo con la formula coincidir, as铆;
=Buscarv(dato a buscar; matriz; coincidir(dato a buscar;matriz);falso)

Para el ejemplo de Expectativa inversi贸n e inversi贸n real
ubicada en columna 10 y 11 de la base de datos
Se puede usar solo una formula para que te traiga ambos valores,usando el n煤mero de columnas entre las llaves {} separando por coma cada una de las columnas, el 煤ltimo cero representa coincidencia exacta, como se muestra a continuaci贸n:
=BUSCARV($E$10,$B$13:$N$113,{10,11},0)

[](`

Si tienen una base de dato con muchas columnas, en donde hay que poner la columna, pueden colocar la funcion COINCIDIR. =BUSCARV(E4;$B$14:$L$113;COINCIDIR(F3;$B$13:$N$13;0);0)
Esto les ahorra contar la columna y lo hace automatico.

Reto superado:
=+VLOOKUP(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSE)

Chequen la nueva funcion BUSCARX, elimina muchos de los problemas de referencias en BUSCARV, puedes buscar en columnas, filas, entre otras mejoras

https://support.microsoft.com/es-es/office/funci贸n-buscarx-b7fd680e-6d10-43e6-84f9-88eae8bf5929

Listo, reto superado.
Lo realize con la siguiente formula =+BUSCARV(B14,鈥楥lase 17.2鈥!$B$4:$N$103,12,FALSO)

馃榿

No entend铆a porqu茅 me daba error, revisando bien me di cuenta que el numero de columna no es por el libro, sino por la tabla, de ahi se hace el conteo , yo estaba contando desde columna A, igual a 1, columna B igual a 2, jajaja.

Tambien se puede utilizar la funci贸n Columnas para traer el valor del indicador de columnas.
.
La formula del ejercicio quedar铆a de la siguiente manera:

BUSCARV(B14,鈥楥lase 17.2鈥!B4:$N$103,COLUMNAS(鈥楥lase 17.2鈥!B3:$M$3),FALSO)

Bueno en lo personal me gusta mas, convertirlas en tablas las bases de datos, es m谩s f谩cil usarlas con con buscarV

+BUSCARV(B14,鈥楥LASE17.2鈥!$B$A:$N$103,12,FALSO)

Yes!

Excelente curso !! s煤per claro y bien explicado

En la versi贸n de Microsoft Office Excel 2019 Pro Plus o Microsoft Office Excel 365 2019, Excel aposto por incorporar una nueva formula que mejore los problemas que presentava Buscar V o H y esta funci贸n es Buscar X.

Para m谩s informaci贸n del uso de la formula les dejo el enlace sigiente: Clic Aqu铆

=BUSCARV($B$14:$B$113;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSO)

Esta f贸rmula me funcion贸 correctamente para encontrar la inversi贸n real de 2017 =+BUSCARV(B14;鈥楥lase 17.2鈥!$B$3:$N$103;12;FALSO)

Reto de Clase:

Done

La funcion COINCIDIR nos indica el orden de un elemento buscado (sea texto o numero) dentro den un rango.
.
Como en el caso del ejemplo en BUSCARV, para tener la certeza del orden de la columna que se busca dentro de un rango de trabajo.
.

Estoy muy feliz de poder entender lo que no supieron explicarme en Bachillerato. Muchas Gracias.

Aqu铆 el reto de esta clase

=+VLOOKUP(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSE)

Ejercicio

Al hacer la actividad propuesta me di cuenta de que uno se debe fijar bien en las formulas, parece obvio pero por no poner un espacio despu茅s del punto y coma no me estaba dando resultado.

Muy buena la practica y se puede traer informacion de varias hojas o archivos:

INVERSION REAL 2017:
=+BUSCARV(B14,鈥楥lase 17.2鈥!B4:N103,12,FALSO)
INVERSION REAL 2016:
=+BUSCARV(B14,鈥楥lase 17.2鈥!B4:N103,13,FALSO)

=+BUSCARV(B14,鈥楥lase 17.2鈥!$B$4:$N$103,12,FALSO)

Listo

=+BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSO)

=+BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSO)
Inversi贸n real 2017
$ 96.781.441
$ 92.963.332
$ 49.599.457
$ 3.248.026
$ 37.561.085
$ 59.142.617
$ -

Ok.

Con este curso se aprende o se aprende!

E

Hola al realizar el reto me queda de la siguiete manera:
=+BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$M$103;12;FALSO)

=BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;0)

Buenos d铆as!
La f贸rmula para obtener la Inversi贸n Real 2017 es as铆:
=+BUSCARV(B14;鈥楥lase 17.2鈥!B4:$N$103;12;FALSO)

=+BUSCARV(B14,鈥楥lase 17.2鈥!$B$4:$N$103,12,FALSO)

Porque debemos poner un 2?

![](

Excelente clase!

Inversi贸n real 2017
=BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSO)

Maravilloso el BUSCARV!

Inversi贸n Real 2017 =+BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;12;FALSO)
Inversi贸n Real 2016 =+BUSCARV(B14;鈥楥lase 17.2鈥!$B$4:$N$103;鈥楥lase 17鈥!$N$12;FALSO)

Inversi贸n real 2017
$ 96.781.441
$ 92.963.332
$ 49.599.457
$ 3.248.026
$ 37.561.085
$ 59.142.617
$ -
$ 53.291.805
$ 50.085.574
$ 67.846.781
$ 56.939.610
$ -
$ 45.347.826
$ 71.453.938
$ 22.346.275
$ 96.357.193
$ 67.375.493
$ 80.671.052
$ -
$ 62.106.884
$ 99.819.688
$ 34.214.902
$ 7.121.108
$ 48.185.946
$ 18.047.519
$ 32.268.145
$ 21.224.611
$ 85.434.615
$ 68.725.539
$ 904.543
$ 66.204.884
$ 30.987.169
$ 24.476.166
$ 15.619.630
$ 96.438.403
$ -
$ 13.211.402
$ 50.796.112
$ 38.721.754
$ 5.161.300
$ 2.565.664
$ 10.860.215
$ 2.659.881
$ 31.746.355
$ 64.667.814
$ 74.083.223
$ 67.753.952
$ -
$ -
$ 33.368.202
$ 46.563.396
$ 98.137.438
$ -
$ 72.192.037
$ 69.870.077
$ 88.265.167
$ 46.917.910
$ -
$ 86.323.763
$ 96.750.826
$ 62.448.793
$ -
$ 96.066.942
$ 24.514.428
$ 40.068.224
$ 62.381.180
$ 34.584.522
$ 76.942.676
$ 19.588.762
$ 85.955.846
$ 39.843.357
$ 82.583.322
$ 42.451.842
$ 49.624.160
$ 44.422.091
$ -
$ 8.030.175
$ 12.862.402
$ 46.914.257
$ 95.212.463
$ 74.493.461
$ 43.223.505
$ 14.141.858
$ 29.525.162
$ 29.366.791
$ 73.195.518
$ 1.432.950
$ -
$ 74.231.711
$ 27.090.183
$ 20.898.506
$ 69.132.389
$ 26.450.622
$ -
$ 39.252.741
$ 3.765.621
$ -
$ -
$ -
$ 24.965.127

Inversi贸n real 2016
$ 47.643.060
$ 47.565.587
$ -
$ 27.143.270
$ 19.598.007
$ 95.314.026
$ 67.714.973
$ 84.809.282
$ 42.495.353
$ 87.726.693
$ 92.726.884
$ 22.994.819
$ 14.301.768
$ 38.593.802
$ 73.743.047
$ 67.901.582
$ 4.753.995
$ 58.339.670
$ 44.898.366
$ 85.228.190
$ 24.233.431
$ 24.896.611
$ 6.991.703
$ 75.039.300
$ 3.738.158
$ 13.339.687
$ 62.562.457
$ 79.508.333
$ 78.613.526
$ -
$ 27.801.447
$ 7.339.680
$ -
$ 59.838.390
$ 90.723.423
$ 52.936.315
$ -
$ 72.757.830
$ 77.230.635
$ 85.417.673
$ 39.602.953
$ 28.637.290
$ 80.287.314
$ 80.063.468
$ 70.653.180
$ 31.617.670
$ 77.205.812
$ 27.651.635
$ 44.671.760
$ 43.277.527
$ 63.313.535
$ -
$ 46.980.526
$ 21.247.716
$ 98.441.580
$ 56.002.928
$ 47.557.281
$ 22.675.260
$ 20.929.788
$ 31.435.769
$ 26.812.600
$ 39.864.620
$ 3.767.736
$ 27.890.231
$ 80.951.038
$ 6.508.585
$ -
$ 74.216.691
$ 78.634.577
$ 25.891.596
$ 64.840.967
$ 809.058
$ -
$ 17.854.677
$ 8.898.260
$ 63.436.099
$ 37.676.206
$ 68.922.404
$ 43.734.508
$ -
$ 151.779
$ -
$ 87.162.317
$ -
$ 89.805.774
$ 10.695.678
$ 29.672.451
$ 97.234.303
$ 42.951.226
$ 79.518.711
$ 24.525.645
$ 99.564.796
$ 4.227.264
$ 54.376.640
$ 15.542.722
$ 18.125.151
$ 62.249.765
$ 1.234.692
$ 174.626
$ 41.129.782

Inversi贸n real 2017
$ 96,781,441
$ 92,963,332
$ 49,599,457
$ 3,248,026
$ 37,561,085
$ 59,142,617
$ -
$ 53,291,805
$ 50,085,574
$ 67,846,781
$ 56,939,610
$ -
$ 45,347,826
$ 71,453,938
$ 22,346,275
$ 96,357,193
$ 67,375,493
$ 80,671,052
$ -
$ 62,106,884
$ 99,819,688
$ 34,214,902
$ 7,121,108
$ 48,185,946
$ 18,047,519
$ 32,268,145
$ 21,224,611
$ 85,434,615
$ 68,725,539
$ 904,543
$ 66,204,884
$ 30,987,169
$ 24,476,166
$ 15,619,630
$ 96,438,403
$ -
$ 13,211,402
$ 50,796,112
$ 38,721,754
$ 5,161,300
$ 2,565,664
$ 10,860,215
$ 2,659,881
$ 31,746,355
$ 64,667,814
$ 74,083,223
$ 67,753,952
$ -
$ -
$ 33,368,202
$ 46,563,396
$ 98,137,438
$ -
$ 72,192,037
$ 69,870,077
$ 88,265,167
$ 46,917,910
$ -
$ 86,323,763
$ 96,750,826
$ 62,448,793
$ -
$ 96,066,942
$ 24,514,428
$ 40,068,224
$ 62,381,180
$ 34,584,522
$ 76,942,676
$ 19,588,762
$ 85,955,846
$ 39,843,357
$ 82,583,322
$ 42,451,842
$ 49,624,160
$ 44,422,091
$ -
$ 8,030,175
$ 12,862,402
$ 46,914,257
$ 95,212,463
$ 74,493,461
$ 43,223,505
$ 14,141,858
$ 29,525,162
$ 29,366,791
$ 73,195,518
$ 1,432,950
$ -
$ 74,231,711
$ 27,090,183
$ 20,898,506
$ 69,132,389
$ 26,450,622
$ -
$ 39,252,741
$ 3,765,621
$ -
$ -
$ -
$ 24,965,127

En ingles:
+VLOOKUP --> BUSCARV
+IFERROR鈥> SI.ERROR