No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

Formula tus propios BuscarV

21/38
Recursos

Aportes 264

Preguntas 7

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad?

Para m铆 lo m谩s f谩cil en este tipo de situaciones es asignarle un nombre a los rangos, en este caso cre茅 un rango que empezaba desde la segunda columna llamado BaseDesdeCorreo (excluyendo la 1ra columna nombre). As铆 al utilizar la funci贸n +BuscarV el rango se referencia de forma f谩cil y r谩pida.

Valor buscado: Correo
Matriz_tabla: BaseDesdeCorreo
Indicador_columnas: ( # de columna - 1 )

El - 1 es porque se empieza a contar desde el correo que es la 2da columna.
Rango: FALSO

Es posible hacer esto MUCHO m谩s r谩pido poniendo la f贸rmula UNA SOLA VEZ y arrastrando hacia arriba y hacia abajo usando # de columna con f贸rmula

  • El valor buscado hay que fijar columnas
  • La matriz de b煤squeda se fija toda.
  • El # de columna se fija filas.

Queda algo as铆 por ejemplo para Expectativa Inversi贸n 2018:

=BUSCARV($C9,'Base de datos'!$B$4:$N$103,Reto!K$7,FALSO)

Cada vez que avanzo un paso en este curso me doy cuenta de lo poco que sab铆a de excel y de lo mucho que ayuda en el mundo comercial.

Hola
mi aporte para la clase.
Por ejemplo para la columna 鈥淐alificaci贸n Feria鈥, mi excel est谩 en ingl茅s, esntoces BuscarV es VLookUP
=VLOOKUP(C10,鈥楥lase 21 Base de Datos鈥!B3:M102,鈥楥lase 21鈥!$I$7,FALSE)
![](

MIN 5:00 debes fijar la celda H7 =+BUSCARV(B9;鈥楤ase de datos鈥!$B$4:$N$103;Reto!$H$7;FALSO)

Otra forma de encontrar el n煤mero de columna es con la funci贸n COLUMNA. Para este ejercicio se restan dos ya que es la primera columna vac铆a y el nombre

=COLUMNA('Base de datos'!G3)-2

Para la columna 鈥淒etalle inversi贸n鈥:

Opci贸n 1: correr el rango de b煤squeda una columna, de manera que la columna Mail, quede como la primera. En este caso es v谩lico porque p谩ra las b煤squedas no se est谩 teniendo en cuenta la columna NOMBRE:

=BUSCARV(B9;'Base de datos'!$B$4:$N$103;7;0)

Opci贸n 2: debido a la limitaci贸n de BUSCARV (solo puede buscar de izquierda a derecha, es decir el valor a buscar debe estar en la primera columna), en su lugar podemos utilizar INDICE y COINCIDIR:

=INDICE('Base de datos'!$B$4:$N$103;COINCIDIR(Reto!C9;'Base de datos'!$C$4:$C$103;0);6)

yo lo hice asi, como valor buscado use el correo, y la matriz de busqueda la seleccione a partir del correo, es as铆 como para mi el indicador de columnas para intencion frente a proyectos era 4, quedandome formula as铆: =BUSCARV(C9;鈥楤ase de datos鈥!$C$4:$N$103;4;FALSO), luego en otra formula nombre la matriz de busqueda con el nombre 鈥渂asecorreo鈥 hice de nuevo la formula para buscar calificacion de proyectos, quedandome la consulta as铆 =BUSCARV($C9;basecorreo;F98;FALSO),

=+BUSCARV($C9**;鈥楤ase de datos鈥!$C$4:$N$103;H$7**;FALSO)
Ahi les traigo como pueden hacer en una sola columna usando la fijaci贸n de datos luego jalar toda la base de datos para no tener que hacer columna por columna.

![](https://static.platzi.com/media/user_upload/image-d15afc20-271c-4fea-a66f-9eb606aaed72.jpg)![](https://static.platzi.com/media/user_upload/image-799a7b5a-b8cb-4f99-8533-1eb1d1ca874a.jpg)
Funci贸n COINCIDIR o MATCH. Cuando se tienen dos bases de datos, como estas, con los mismos t铆tulos en las columnas, se puede usar esta funci贸n para que indique en qu茅 posici贸n est谩, indiferente del orden. Lo que hice fue nombrar el rango de t铆tulos en la tabla que est谩 completa (Titulos), tambi茅n nombre la base de datos (tblData) y agregu茅 la funci贸n si.error 贸 iferror: \=IFERROR(VLOOKUP($B9;tblData;**MATCH(F$8;Titulos;0)**;0);"Revisar") Con esta 煤nica f贸rmula se puede traer toda la informaci贸n, pero es muy importante fijar los rangos de manera adecuada. Practica primero usando 煤nicamente la funci贸n coincidir o match, as铆: MATCH(F$8;Titulos;0)

Bingo!.. Items completados usando correo electr贸nico como elemento com煤n.
https://1drv.ms/x/s!Ao1ipRMyncdAjTv6KL4gECKoZfbL?e=XWHYMw

HOLA, para hacer la tarea, en base al correo, y como dice el profe siempre debe estar en la primera columna, lo que hice fue pasar la columna de correos para atr谩s de la de nombre y as铆 lo logre.

Corrijo no hab铆a visto las indicaciones, =BUSCARV($C9,鈥楤ase de datos鈥!$C$4:$N$103,J$7,0) ya solo en donde referencias el n煤mero de columnas le resta 1 columna y listo.

=BUSCARV($B10,鈥楤ase de datos鈥!$B$4:$N$103,Reto!N$7,0) yo lo hice as铆, y de esta forma cuando jalas la f贸rmula hacia abajo y hacia la izquierda te da toda la informaci贸n superr谩pido.

RETO RESUELTO

  1. Oculte la columna de nombre en las dos hojas de Excel y asi deje la de correo primero.
  2. Hice la formula que ya aprendimos.
    =VLOOKUP(C9;鈥楤ase de datos鈥!C4:N103;5;TRUE)

=+BUSCARV(C9;鈥楤ase de datos鈥!$C$4:$N$103;Reto!$H$7;FALSO)

Es aplicar esta misma formula pero cambiar la celda de referencia de la informaci贸n en cada caso. Como nuestro param茅tro de b煤squeda es el correo electr贸nico, debemos iniciar desde la Celda C4.

Reto cumplido

Tienes que estar atento cuando aplicas la formula y poner arriba en cada columnal numero para que no te confundas, es una buena practica

Como consejo porque me ha pasado, Buscarv va a traer el valor exacto que le des a buscar.
Es decir por ejemplo si en una base de datos tienen 鈥淏ogota鈥 pero en la otra tienen 鈥淏ogot谩鈥 (con tilde) La formula no va a encontrar el valor.
Por si alguna vez les falla la formula siempre revisar como esta escrito el valor buscado en ambas bases de datos.

Utilize coincidir para encontrar la Columna y la matriz la seleccione desde la segunda columna de la tabla para que identificara los correo como valor buscado

Reto Cumplido

Reto Cumplido.

=BUSCARV(C9;鈥楤ase de datos鈥!$C$4:$N$103;Reto!$I$7;FALSO)
LA FORMULA QUE USE PARA AHCER EL RETO, UNICAMENTE CAMBIE LA MATRIS Y SELECCIONE COMO PRIMERA COLUMNA EL MAIL Y NO EL NOMBRE.

reto cumplido

Reto Cumplido:.

A M O este tipo de cursos 鉂わ笍
Antes no me simpatizaba excel pero ahora me doy cuenta de lo inmensamente 脷TIL que puede ser para TODAS las 谩reas 馃槃
@Platzi, por favor saquen m谩s cursos de excel como este, ya tom茅 los otros (excel b谩sico e intermedio), pero personalmente pienso que la forma de explicar de @FelipeGuzmanBotero es excelente!! 馃槑
隆Muchas gracias y feliz pr贸spero a帽o 2023!

Utilizando la siguiente estructura de la formula BuscarV 馃憞
.
=BUSCARV($C9,鈥楤ase de datos鈥!$C$4:$N$103,COLUMNAS(鈥楤ase de datos鈥!$C$3:F$3),FALSO)
.
Pueden ubicarse en la primera celda de la columna Intenci贸n frente a los proyectos y desplazar la formula hacia a la derecha y hacia bajo para la soluci贸n r谩pida del ejercicio.

Lo que hice para el reto fue, seleccionar el rango de la matriz de la hoja base de datos desde el correo y no desde el nombre, por lo que a la posici贸n de las columnas se le restar铆a un lugar. Luego fij茅 para llenar la tabla en segundos.

Si fijan todo, pueden arrastrar la f贸rmula y el ejercicio quedar谩 resuelto en unos segundos.

Formula tus propios Buscarv

Cuando se contruyen bases de datos se puede tener diferentes tipos de informacion relacionada a un mismo registro en diferentes tablas. Buscarv es muy util en estos casos porque permite unificar esta informacion en otra hoja o base de datos para asi construir BD mucho mas completas.

Reto Formula Tus Propios BUSCARV

(Secci贸n Formulada principalmente)Yo lo que hice fue darle un nombre a la base de datos c贸mo 鈥榖d鈥

  1. Ancl茅 la columna del dato que buscaba (correos) con $C9
  2. Ancl茅 las filas de mis 铆ndices para no hacerlo manualmente H$7 y que fuese corriendo de forma horizontal
=+BUSCARV($C9,'reto-formula-tus-propios-buscar-v.xlsx'!bd,Reto!H$7,FALSO)

馃懢

隆Muy buen reto, muchas gracias!

Recuerden la clase de fijaci贸n de datos.
Les ayudar谩 para jalar la f贸rmula para las siguientes columnas.

Para la primera parte
=+BUSCARV(C9,Basedata,5,FALSO)

Para la segunda parte
=+BUSCARV($C$9,Basedata,I7,FALSO)
Basedata es mi matriz fija desde la columna mail hasta el 煤ltimo datos
El resto fue copiar pegar y actualizar (f9)

Como aporte a la clase, no olvidar que si queremos extender y aplicar la f贸rmula para rellenar toda la base de datos, debemos fijar la celda que nos establece el indicador de columna.

Me parece importante recordar que debido a que iniciamos la b煤squeda en la columna de correo electr贸nico (la columna 2), al momento de establecer el indicador de columna para la b煤squeda, se empieza a contar desde la primera columna seleccionada, es decir, el indicador ser铆a el 5 aunque es la columna 6 (o bueno, as铆 me funcion贸).

Estuvo muy bueno el reto! Me gusto.

Reto en Clase:

Luego cada una de las formulas se arrastra al final de la base.

Reto espero este bien !

Soluci贸n:
https://docs.google.com/spreadsheets/d/1-OzZl4N0Yqj3r6zY4Aqg_x30AxHxYSuYEdpqzaq1IYY/edit?usp=sharing
Shortcourts utiles:
Cambio de hoja:Ctrl + AvPag / Ctrl + RePag
Home:Ctrl + Inicio
F4:Fijaci贸n de rangos

Pasos para la soluci贸n

OK Reto

=+VLOOKUP($C9;鈥楤ase de datos鈥!$C$4:$N$103;Reto!H$7;)

=+BUSCARV(C9;鈥楤ase de datos鈥!$C$4:$N$103;4;FALSO)

Solo seleccionan desde la columna donde empieza el correo, tom谩ndola de esta manera como primera.

Resumen:

En esta clase se explica un poco m谩s la funci贸n BuscarV(), las ventajas de tener el indicador de columnas como formulada, las cuales se podr铆an concretar en que es posible unificar la informaci贸n en otro rango de una tabla con diferente n煤mero de columna.

=+BUSCARV(C9;鈥楤ase de datos鈥!$C$3:$N$103;5;FALSO)

Nota: recuerden que cuando el indicador de columna nos tenga que dar datos num茅ricos debemos fijar esa columna igual como lo hacemos con la matriz.

Para el ejemplo solicitado inici茅 desde la columna email tal como pide el profe, luego seleccion茅 la matriz de la base de datos a partir del email (osea descart茅 la columna de nombres), luego el indicador de columna (datos que quiero traer a mi nueva tabla) ojo(al traer datos num茅ricos debes fijarla), y por 煤ltimo el tipo de coincidencia que como todos sabemos debe ser FALSO, para tener una coincidencia exacta y no aproximada.

Tip: Para conocer el indicador de columna sin estar contando se podria usara =COINCIDIR
Ejemplo:
=COINCIDIR(鈥楥onoce alg煤n proyecto o no鈥,鈥楤ase de datos鈥!$C$3:$N$3,0) y les devolvera la posici贸n relativa de la columna a indicar.

Nota: Se hace desde 鈥楳ail鈥 porque desde ah铆 iniciar铆a nuestro buscarv

Reto realizado

Aqu铆 ya considero el correo.

=BUSCARV(C10,鈥楤ase de datos鈥!$C$5:$H$103,Reto!$H$7-1,FALSO)

Solucion: =+BUSCARV(C10;鈥楤ase de datos鈥!$C$4:$N$103;4;FALSO)

Si ya se conoce el n煤mero de columna no es necesario seleccionar toda la base de datos, se puede seleccionar hasta la colunma que se conoce y BUSCARV funcionar谩

RETO BUSCARV

![](

Buenas noches

Reto cumplido

Att Fredy Sarmiento

La forma como te simplifica la vida es impresionante

Hola a todos, como pueden visualizar en la imagen, existe una manera m谩s sencilla para conocer el n煤mero de la columna.

Al momento de seleccionar la matriz d贸nde quieren buscar su valor, en la parte inferior puede visualizar la ubicaci贸n exacta (toman en cuenta el segundo d铆gito).

Espero les funcione
Saludos 馃槂

Reto cumplido.

Dominar el BuscarV es sumamente gratificante. Es una gran herramienta.

=+BUSCARV($C9,鈥楤ase de datos鈥!$C$4:$N$103,J$7,FALSO)

reto realizado

=+BUSCARV($C11,鈥楤ase de datos鈥!$C$4:$N$103,F$7,0)
En la primera casilla luego se arrastra lateral desues hacia abajo y listo.