No tienes acceso a esta clase

¡Continúa aprendiendo! Únete y comienza a potenciar tu carrera

Fórmulas condicionales. ¿Qué son?

24/38
Recursos

Aportes 59

Preguntas 7

Ordenar por:

¿Quieres ver más aportes, preguntas y respuestas de la comunidad?

Formato condicional a que cambie de color la celda:

SELECCIONAS LAS CELDAS DE RESULTADOS, FORMATO CONDICIONAL(Barra de herramientas), NUEVA REGLA, ESTILO CLASICO(depende de su configuración), APLICAR FORMATO UNICAMENTE A LAS CELDAS QUE CONTENGAN, TEXTOS ESPECIFICO, QUE CONTENGAN, “Nombre del resultado”,SELECCIONA RESULTADO A COLOR, ACEPTAR.

![](

consejo, traten de hacer condicionales que puedan cambiarse en el momento sin tener que hacer muchos pasos. Esto por ejemplo en la industria manufacturera es muy necesario e indispensable. Pues las bases de datos de produccion varian mucho segun lo que se este produciendo y las metas.

Formulas condicionales

Elementos que tiene una prueba logica

  • Prueba logica
  • valor verdadero
  • valor falso

= SI( prueba logica ; valor verdadero; valor falso )

= Si( c10= j; " platzi “; " rojo” )

condicionales anidados

Significa que va a existir una condición coformada por más condiciones, así:

ejemplo :

=Si(c10=2;“platzi”; SI(c10=“k”;“platzi”; rojo))

Me parece muy eficaz la forma en la que Felipe explica la lógica detrás de las fórmulas condicionales, lo entendí completico 😄

Si sabes programar eso se te hará super sencillo ya que lo miras muy seguido

Condicionales anidados.

El si condicional funciona igual que el algebra en la restricción, para ahorrarse un si en árbol, pueden poner “o”, como se ve en la imagen, además funciona igual con las funciones Y y No. (pueden comparar más de dos elemento)

Resumen:

En esta clase contemplamos las formulas condicionales que me permiten realizar pruebas lógicas mediante comparación de argumento, así como integrar diferentes condicionales para evaluar múltiples argumentos.

para que cambie de color la celda debes usar la opción de formato condicional en la pestaña de inicio.

a la hora de poner una condicion, cuando es número va sin " "

Como se hace la validacion con colores debido a que cambia el resultado asigna un color distinto?

Este curso es muy bueno, yo estudié en un colegio con con bases en excel y este me ayudó a entender mucho de excel, pero aún con todo lo aprendido en ese tiempo este curso resulta ser muy bueno

tambien se pueden combinar con ortras formulas y realizar operaciones wow!!

=SI(ESNUMERO(HALLAR("/1";B3));“Gerenciamiento”;
SI(ESNUMERO(HALLAR("/2";B3));“Estudios De Ingenieria”;
SI(ESNUMERO(HALLAR("/3";B3));“Facilidades De Pozo”;
SI(ESNUMERO(HALLAR("/4";B3));“Facilidades De Superficie”;
SI(ESNUMERO(HALLAR("/5";B3));“Workover”;
SI(ESNUMERO(HALLAR("/6-01";B3));“Inversion Social”;
SI(ESNUMERO(HALLAR("/6-02";B3));“Inversion Ambiental”;
SI(ESNUMERO(HALLAR("/6-03";B3));“Otros”;
SI(ESNUMERO(HALLAR("/7";B3));“Escalacion”;
SI(ESNUMERO(HALLAR("/8";B3));“Comisionamiento”;
SI(ESNUMERO(HALLAR("/9";B3));“Accrual”;
" ")))))))))))

Formulas Condicionales

Es una formula que permite condicionar una celda: arroja un resultado si cumple una condicion; arroja otro resultado si no lo cumple.

  • Formula condicional: = SI(prueba_logica;[valor_si_verdadero];[valor_si_falso]). Ejemplo: =SI(C3=“J”;”Verdadero”;”Falso”)
  • Fomula condicional anidada: permite anidar otra condicion a la condicion inicial. La logica es: si cumple la prueba logica arroja el “valor si verdadero”; sino Si cumple segunda prueba logica, arroja el “valor si verdadero”; sino arroja El “valor si falso”. Ejemplo:

=SI(prueba_logica1;[valor_si_verdadero];SI(prueba_logica2;[valor_si_verdadero];[valor_si_falso]))

Este video es una joya, no había visto explicado los condicionales de forma tan sencilla y gráfica.

Excelente clase, es parecido a las celdas con condiciones para establecer formatos de acuerdo a lo que diga una celda, esta función le veo mas diversidad de uso y portabilidad

Ejemplos claros y lúdicos, que buena metodología.

También se pueden usar los operadores AND - OR para en X casos evitar el uso de anidaciones, que en Excel funcionan como las funciones Y - O. Ejemplo.
Función O
Aquí se dan dos condiciones y para que se indique como verdadero, se puede cumplir cualquiera de ellas. Ojo, pueden ser 2,3,4…n condiciones, tú ves, yo usé 2 solo para ejemplo

=SI(O(Condición 1,Condición 2);"Valor si una de las dos condiciones se cumple";"Valor si ninguna de las dos condiciones se cumple")

Funcion Y
Aquí se dan dos condiciones y para que se indique como verdadero, se den cumplir las dos, ya no sirve que solo se cumpla una. Ojo, pueden ser 2,3,4…n condiciones, tú ves, yo usé 2 solo para ejemplo

=SI(Y(Condición 1,Condición 2);“Valor si todas las condiciones se cumplen”;“Valor si no se cumplen todas las condiciones”)

¿Por que no me reconoce el verdadero?
https://prnt.sc/mewacb

muy interesante la formula para calificación de trabajos

Se puede anidar funciones condicionales un máximo de 32 veces o 64 veces? creo que la respuesta es 32 veces, alguien se anima a intentarlo?

Voy hacer mi sistema de conteo de cartas en Excel 😃

me gusta mucho como explica…los temas

Muy inusual y poco aplicable a la vida laboral ese ejemplo

Para ponerle dos condiciones a la función “Si” sin necesidad de anidar otra Si ; en el argumento “valor si verdadero” le puse la función O, y quedaría así:
=Si(O(C18=2;C18=“K”); “Platzi” ; “Rojo” )

Me gusta como explica Felipe estas fórmulas condiconales. Queda muy claro. Gracias.

Excelente explicación, súper didáctica!

Si la calificación de proyecto es mayor a 7, entonces, satisfecho, sino insatisfecho
=SI(J12>7;“Satisfecho”;“Insatisfecho”)
Si conoce algún proyecto, entonces escribir “Si conoce”, sino escribir “No Conoce”
=SI(H12=“SI”; “Si conoce”; “No conoce”)
Si es de Colomia y es del sector educación, escribir “Elegido”, sino “No elegido”
=SI(D12=“Colombia”;SI(E12=“Educación”;“Elegido”;“No Elegido”);“No elegido”)

interesante esta formula

Es bastante interesante las fórmulas condicionales y el formato condicional. Se utiliza mucho para los indicadores.

Algo que en ocaciones puede funcionar igual que IF, es con la fórmula =EXACT …(sólo en ocaciones)

Es útil para resaltar rápidamente información que consideramos importante dentro de una hoja de cálculo.

hasta aquí, los condicionales están basados en texto, además de los resultados V o F. Las celdas deben estar con un formato condicional para botar cada resultado en colores.

como puedo hacer para que cuando pongo platzi o rojo sea verde o rojo, cuando lo practico no cambia se mantiene
j platzi(negro)
3 rojo(negro)
o si pongo un color a uno cuando sale rojo como respuesta se mantiene el mismo color que el anterior

Buenas Formulas!

Creo otra forma de ver el tema es cn diagramas de flujo, con esto para algunos seria mas facil de entender.

Son formulas que te ayudarán a comparar o identificar si tu argumento tiene un resultado positivo o negativo. Es importante tener claro que no es necesario utilizarlas siempre, solo cuando te agreguen valor a tu análisis.

Quedé en duda de cómo poner los formatos de colores, es en INICIO-FORMATO CONDICIONAL-NUEVA REGLA y aquí aparecen distintas opciones, en caso de ser texto poner APLICAR FORMATOS ÚNICAMENTE A LAS CELDAS QUE CONTENGAN-TEXTO-Y AQUÍ DAR FORMATO.

Lo que es no saber.

Excelente.

Fórmulas anidadas dentro de otras fórmulas.

ejemplos muy claros.

Qué significa colocar el signo + en la formula =+si?

Muy buenos ejemplos, te queda en claro las distintas funcionalidades de las condicionales.

Esta es una herramienta muy útil, lo tedioso es cuando tenes que poner muchos SI() adentro de otros.

Excelente explicación

Una explicación muy didáctica.

excelente explicación para poder entender la fórmula.

esto me era tan útil haberlo sabido desde hace años

Son las tablas de verdad

¿La prueba lógica es sensible a las mayúsculas y minúsculas?

Las fórmulas condicionales son muy eficientes en diversos casos y utilizando diversos métodos.

El condicional es una herramienta muy usada en diagramas de flujo y obviamente en código de programación. Se pueden hacer cadenas largas de esta herramienta. Excelente explicación.

Excelente

Sin duda que una gran herramienta para llenar y analizar las bases de datos.

Aquí está el código del Ejemplo 4 en Python:


Este sería el flujo de la lógica del ejemplo 3 en Python