No tienes acceso a esta clase

¡Continúa aprendiendo! Únete y comienza a potenciar tu carrera

Formulación con tablas dinámicas

32/38
Recursos

Aportes 209

Preguntas 4

Ordenar por:

¿Quieres ver más aportes, preguntas y respuestas de la comunidad?

Listo el reto 12.
=SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”,$B$13,“Intención frente a los proyectos”,C5,“Sector”,C4),“No Hay Registro”)

Resumen:

En esta clase vimos lo que se puede hacer con formular tablas dinámicos e importardatosdinámicos, la idea es que los campos pueden volverse campos formulados, referenciados a una celda con listas diámicas para evitar errores de digitació.

Pd: Amo este curso, lo juro

No se que estoy haciendo mal, porque la formula genera error

Listo
Utilicé la fórmula =SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”,$A$13,“Sector”, B4,“Intención frente a los proyectos”, B5), 0)
para evitar que saliera error cuando no hubo inversión

Formular con Tablas dinámicas

Es un proceso que permite robustecer la formulación. Como las tablas dinámicas reúnen una cantidad amplia de información, cuando formulas puedes llegar a la información de forma especifica

  • Al seleccionar un valor de una tabla dinamica y pasarlo como formula a una celda puedes crear listas desplegables con los valores de interes de la TD y luego modificar la formula de la TD sustituyendo el valor seleccionado por la celda con la lista desplegable. De esta manera, al cambiar el valor de la lista, cambia el valor de la celda de acuerdo alo que se encuentre en la TD

Wow, esta funcionalidad me parece increíble.

Yo usaría Segmentadores en lugar de fórmulas con listas.

Ok.

![](https://static.platzi.com/media/user_upload/image-08201dfd-0375-4e89-8e1d-8a274580f4dc.jpg)
![](https://static.platzi.com/media/user_upload/Captura%20de%20pantalla%20%283%29-f7a431e8-6572-4779-b301-dd910be78865.jpg)
Hecho! :D ![](https://static.platzi.com/media/user_upload/image-7d1cbdf9-a43f-43ce-a907-f05403f696c6.jpg)

=SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”,$A$13,“Sector”, B4,“Intención frente a los proyectos”, B5), 0)


Con la fórmula SI.ERROR evitamos que nos salga

REF cuando no hay valores

Tolis 😄

=SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”;$A$13;“Sector”;B4;“Intención frente a los proyectos”;B5);“Sin info.”)

Tambien lo resolvi usando solo las tablas dinamicas.

Reto superado:

Reto cumplido:
=SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”,$A$13,“Sector”,$B$4,“Intención frente a los proyectos”,$B$5),“No hay Registro”)

Reto cumplido

Estuvo interesante el reto

Reto clase formulación con tablas dinámicas.

Es posible configurar la tabla dinamica de tal forma que en las columnas haya texto??

Llevo alrededor de media hora sin entender lo que estoy haciendo con el ejercicio real, y estoy viendo que fue más sencillo de lo que pensaba. El problema es que no sabía cómo sacar los datos del 2016 porque en el archivo no encontré la base de datos original, pero dando click en la tabla dinámica, me di cuenta, que aunque no los vea los datos están ahí, solo hay que dar click.

Reto 12

Holaaa dejo mi solución hecha en Google Sheet, tardé porque acá se usan formulas diferentes, y se hacía de otras formas
FORMULA: =SI.ERROR(GETPIVOTDATA(“Inversión real 2016”;$A$13;“Sector”;B4;“Intención frente a los proyectos”;B5); “Sin referencias”)

Saludos comunidad 😃))))

Reto cumplido

=SI.ERROR(IMPORTARDATOSDINAMICOS(“Inversión real 2016”;$A$13;“Sector”;B4;“Intención frente a los proyectos”;B5);0)

RETO CONSEGUIDO. FIJARSE MUCHO EN LA SINTAXIS, EN LAS TILDES

hay voy poco a poco!

=IMPORTARDATOSDINAMICOS("Inversión real 2016",$A$13,"Sector",B4,"Intención frente a los proyectos",B5)

No entendía muy bien como funcionaba, una manera sencilla de recordarlo es que solo modificamos el campo de “elemento”

👾

=IMPORTARDATOSDINAMICOS(“Inversión real 2016”;$A$13;“Sector”;K25;“Intención frente a los proyectos”;K26)

COMPARTO MI RESULTADO DE LA TABLA DINAMICA:

Y lo formulé de la siguiente manera:

😃

No me sale el reto ayuda 😢

Es importante considerar el sintaxis en la formulacion.

Reto 12

Reto
Muy útil esta herramienta de las tablas dinámicas!

Reto Fromulacion de Tabla Dinámica

agregar lista desplegable de inversion 2016, 2017 y 2018 y un si, para lograr que los datos cambien de acuerdo a la lista desplegable. Dejo la formula.

=SI.ERROR(IMPORTARDATOSDINAMICOS(SI(A7=“Inversión real 2018”;“Inversión real 2018”;SI(A7=“Inversión real 2017”;“Inversión real 2017”;“Inversión real 2016”));$A$14;A4;B4;A5;B5);“No Hay Registro”)

Cuando hay datos de intención de proyectos

Cuando no hay datos de intención de proyectos

Reto cumplido 😃

Excelente formula!!

=IFERROR(+GETPIVOTDATA(“Inversión real 2016”;$A$13;“Sector”;B5;“Intención frente a los proyectos”;B6);0)

=SI.ERROR((IMPORTARDATOSDINAMICOS(“Inversión real 2016”;$A$13;“Sector”;$B$4;“Intención frente a los proyectos”;$B$5));0)

Esta fue la formula que utilicé.

Muy buena clase 😃

se aplico la formula
"=IMPORTADODATOSDINAMICOS"
Para alterar los resultados del codigo de la tabla dinamica" para afectar los valores que excel por default esta asumiendo que son palabras,para relacionarlos con celdas que despues podemos cambiar y actualizaran el valor final de la celda.

Utilice la formula SI:ERROR para evitar #REF. Saludos
![](

![](

Muy buena

Nunca habia fucionado las listas desplegables asi. Muchas gracias!

El reto

Reto cumplido!

OK![](

Reto15

Buenas tardes, a continuación el link del reto

https://drive.google.com/open?id=11SR0Calh4VmVSfqgbuJ0ZyFo9__hyHwC

Reto 12 cumplido

Reto:

Nueva, no la conocía. Me parece muy propicia.

Resultados del reto: