Profundizar en direccionamiento avanzado

1

Todo lo que aprenderás sobre redes de internet

2

Números binarios fáciles

3

Máscaras, todas las tallas para todos los tamaños

4

Clases de direcciones

5

Apuntes: clases de direcciones

6

Diseño de direccionamiento

7

¿Por qué tenemos direcciones públicas y privadas?

8

Instalación de Packet Tracer

9

Traducción de direcciones públicas a privadas

10

Capa de red, las direcciones públicas se han acabado ¿Qué haremos?

Comprender los servicios de red

11

Nombres para humanos vs nombres para máquinas

12

¿Cómo sabe una máquina quién es? Servicio de asignación de direcciones

Identificar características de enrutamiento

13

Rutas ¿Cuál es la ubicación de las máquinas?

14

Uso de rutas estáticas

15

Configuración de rutas estáticas

16

Rutas dinámicas: cuando los enrutadores aprenden por sí mismos

17

Configuración de rutas dinámicas

18

Apuntes: rutas estáticas y dinámicas

19

Convergencia de enrutamiento, cuando todos los enrutadores están de acuerdo

Diseñar y ejecutar redes locales conmutadas

20

Necesidad del diseño de la topología de LAN

21

Ejecución del diseño de la topología de LAN

22

Redes inalámbricas, los usuarios se mueven por todos lados

23

Diseño de redes inalámbricas

24

Configuración de redes inalámbricas

25

Equipos activos de LAN: el cableado sigue siendo importante

26

Separación de grupos, el uso de las VLAN

27

Enlaces troncales, cuando las conexiones se unen

Identificar y mejorar seguridad en la red

28

Lista de control de acceso: elementos

29

Lista de control de acceso: filosofía

30

Listas de control de acceso, un firewall en reglas

31

Ataques al servicio DNS ¿Qué pasa cuando me engañan con el nombre?

32

Cierre del curso

Crea una cuenta o inicia sesión

¡Continúa aprendiendo sin ningún costo! Únete y comienza a potenciar tu carrera

Traducción de direcciones públicas a privadas

9/32
Recursos

Aportes 68

Preguntas 15

Ordenar por:

¿Quieres ver más aportes, preguntas y respuestas de la comunidad?

Voy a dar mi criterio sobre este tema, creo que si se supone que la gran mayoría de las personas no tenia instalado o sabían usar packet tracer como mágicamente de forma casi instantánea después de instalarlo y sin ninguna otra instrucción se va iniciar viendo NAT eso no tiene lógica algunas.

Además solo explica de forma magistral que sea hace pero no como se realizo el proceso y si una persona nunca a programado un router virtual le va parecer muy extraño todo lo que esta diciendo el docente.

dejo la siguiente dirección con la finalidad, para e interesado de ver como se realiza el NAT en el proceso con los comandos de packet tracer

https://www.mikroways.net/2010/06/06/tipos-de-nat-y-configuracion-en-cisco/

Pero cómo se configura el Router 2?? Escribiendo encima, con comandos, cómo?

Super mala esta clase, no se entiende nada, la profesora perdió la noción de la continuación del curso

Esta es mi práctica de nat: https://drive.google.com/file/d/1eIG4daQZRdS-1C6wPkztFmmmy9-24r8T/view?usp=sharing

Además anexo los comando que utilice para cada router:

########################  R0  #######################################
enable
conf t
interface Gig0/0
ip address 192.168.1.1 255.255.255.128
no shutdown
exit
interface Se0/0/0
ip address 192.168.1.193 255.255.255.252
no shutdown
exit
interface Se0/0/1
ip address 192.168.1.197 255.255.255.252
no shutdown
exit
exit

conf t
route rip
version 2
no auto-summary
network 192.168.1.0
network 192.168.1.192
network 192.168.1.196
do write
ip dhcp pool red1
network 192.168.1.0 255.255.255.128
default-route 192.168.1.1
exit
ip dhcp excluded-address 192.168.1.1
exit
copy run start
########################  R1  #######################################
enable
conf t
interface Gig0/0
ip address 192.168.1.129 255.255.255.224
no shutdown
exit
interface Se0/0/0
ip address 192.168.1.194 255.255.255.252
no shutdown
exit
interface Se0/0/1
ip address 192.168.1.201 255.255.255.252
no shutdown
exit
exit

conf t
route rip
version 2
no auto-summary
network 192.168.1.128
network 192.168.1.192
network 192.168.1.200
do write
ip dhcp pool red2
network 192.168.1.128 255.255.255.224
default-route 192.168.1.129
exit
ip dhcp excluded-address 192.168.1.129
exit
copy run start
#########################  R2  ######################################
enable
conf t
interface Gig0/0
ip address 190.200.10.1 255.255.255.240
no shutdown
exit
interface Se0/0/0
ip address 192.168.1.198 255.255.255.252
no shutdown
exit
interface Se0/0/1
ip address 192.168.1.202 255.255.255.252
no shutdown
exit
exit

conf t
route rip
version 2
no auto-summary
network 190.200.10.0
network 192.168.1.196
network 192.168.1.200
do write
ip dhcp pool Inter
network 190.200.10.0 255.255.255.240
default-route 190.200.10.1
exit
ip dhcp excluded-address 190.200.10.1
exit

conf t
access-list 1 permit 192.168.1.0 0.0.0.127
ip nat pool rangored1 190.200.10.4 190.200.10.10 netmask 255.255.255.240
ip nat inside source list 1 pool rangored1
access-list 2 permit 192.168.1.128 0.0.0.31
ip nat pool rangored2 190.200.10.11 190.200.10.14 netmask 255.255.255.240
ip nat inside source list 2 pool rangored2
interface Gig0/0
ip nat outside
exit
interface Se0/0/0
ip nat inside
exit
interface Se0/0/1
ip nat inside
exit
exit
copy run start

Existe varios tipos de NAT:

NAT estático: Se basa en realizar traducciones de una única IP publica a una única IP privada. esto se conoce como “one to one”.

NAT dinámico: Técnica que la profe utilizo en el ejemplo. Se basa en realizar traducciones de varias IPs publicas a Privadas, en este casa deberíamos tener las mismas IPs publicas como IPs privadas, de lo contrario si por ejemplo tenemos mas IPs privadas que es lo mas común, habrán equipos que no podrán salir a internet.

NAT overload (o PAT): Usado en redes domesticas. Se basa en realizar traducciones de una única IP publica a varias IPs privadas por medio de puertos.

creo que hace falta mucha más claridad en el tema, pues pese a tener conocimientos previos y haber tomado el curso básico, me veo obligado a buscar la gran mayoría de información en la web.

La verdad no se en que momento aprendi a configurar el router, solo se menciono y se mostró superficialmente lo que ya estaba configurado

Me toco realizar otro curso, en la competencia donde si explicaban paso a paso como llegar a este punto, el curso de redes básico es MUY básico, solo se vieron conceptos generales, y acá ya asumen que uno sabe entrar al router y conoce los comando para llegar donde ella llego. Malas expectativas con este curso

Para quienes no han usado Packet Tracer nunca, recomiendo tomar el curso gratuido de induccion a packet tracer en Netacad de cisco y como aporte al tema de esta clase, comparto a quienes esten interesados la configuracion de NAT dinamica con sus comandos en el siguiente link.

tan bien que iba el curso, me decepciona que algunos cursos como este den saltos enormes en el proceso de aprendizaje, parece que me da lo mismo ver tutoriales en youtube donde explican mejor el nat. profesores de platzi !! marquen la diferencia no obliguen a uno a tener que irse por este tipo de vacios en sus clases

No entendi nada, y por lo que veo no hay un curso intermedio donde me explique como funciona y como usar Paket Tracer, ahora estoy estancado. Por favor alguien que me ayude explicandome mejor esta clase.

*************router PRI****************************
hostname Router2

---router2
interface gigaEthernet 0/0
ip address 190.200.10.13 255.255.255.240
ip nat outside
no shutdown
---
interface Serial 0/0/0
ip address 192.168.1.198 255.255.255.252
ip nat inside
no shutdown
--
interface Serial 0/1/0
ip address 192.168.1.201 255.255.255.252
ip nat inside
no shutdown
--
Router(config)#router ospf 100
Router(config-router)# network 192.168.1.196 0.0.0.3 area 50
Router(config-router)# network 192.168.1.200 0.0.0.3 area 50
Router(config-router)# network 190.200.10.0 0.0.0.15 area 50
!
access-list 1 permit 192.168.1.128 0.0.0.31
access-list 1 permit 192.168.1.0 0.0.0.127
!
router(config)#ip nat pool NAT_POOL 190.200.10.4 190.200.10.5 netmask 255.255.255.240
ip nat inside source list 1 pool NAT_POOL
!

Hola inge, entonces si estoy entiendiendo bien, cuando una empresa tiene varias sedes dispersos en distintos lugares o ciudades, para enlazar esas sedes y tener comunicación a su nodo central o sede principal, debe proceder a configurar los routers que suministran las direcciones publicas que suministran los proveedores de internet para que estos se hablen y se conecten como si estas sedes fueran una sola red privada.

Para los perdidos que comienzan como yo: Les va un par de pasos:

1)Entran al router.
2)enable
3)config terminal (Aqui comenzamos a colocar los comandos):
4)interface Serial0/1/0
ip nat inside
exit

5)interface Serial0/1/1
ip nat inside
exit

6)interface FastEthernet0/0
ip nat outside
exit

Esta pagina me ayudo a traducir la mascara wildcard:
https://www.subnetonline.com/pages/subnet-calculators/ipv4-wildcard-calculator.php

  1. access-list 1 permit 192.168.1.1 0.0.0.127
    acces-list 1 permit 192.168.1.29 0.0.0.31
    (La direccion ip del router y la mascara willdcard)

  2. ip nat pool MY_POOL 190.200.10.20 190.200.10.254 netmask 255.255.255.0

9)ip nat inside source list 1 pool MY_POOL

En caso de que la oficina con 100 host no realize el ping.
entrar en la configuracion del router 0 y colocar:

no access-list 101

Siento se saltaron unos 5 o 6 pueblos con esta clase

El Router0 tiene un ACL que no permite alcanzar la IP pública del servidor web.
Yo la eliminé con:

Router(config)#no access-list 101

Por si acaso quiera ver más a detalle packet tracer les dejo este curso. se los recomiendo.
https://www.youtube.com/watch?v=kydZEZwr4cQ&list=PLYAyQauAPx8niwPYnDOFynhmHiQlXlG5K

Extra ayuda para los que lean esto:

Un pool: es un conjunto de varias IP´s de un mismo segmento de red.

Nat : Traduces IPs de un segmento a otro. El mas común es convertir IPs privadas a publicas. (Network address translation)

Que hacen los comandos que explica Isabel?


1_ ip nat inside
Inside: Reciben el trafico de IPs Privadas. Isabel tambien les dice ‘que la inside reciben trafico interno’. (que es lo mismo que decir privadas)

2_ ip nat outside
outside: Sacan el trafico hacia internet con las IPs Publicas.

3_ access-list 1 permit 10.0.0.0 0.0.0.255
list 1: Listas de control de acceso que nos van a permitir saber cuales son origenes de trafico que van a ser recibidos y traducidos a direcciones publicas.

4_ ip nat pool STUDY-CCNA_POOL 155.4.12.1 155.4.12.3 netmask 255.255.255.0
ip nat pool: Crea un pool de direcciones que nos permite determinar que ips publicas vamos a tener disponibles para ser traducidas desde las direcciones privadas.

5_ ip nat inside source list 1 pool STUDY-CCNA_POOL
ip nat inside source list 1 pool: Aplicamos una lista de control de acceso que nos va a decir que esas direcciones NAT de esa lista van a utilizar ese pool especificamente para ahcer la traduccion.

❤ - Lo mas importante para comenzar a escribir en el CLI del router (command-line interface) solamente tiene que presionar la tecla Enter.

No es error de la profe, es que llegamos con malas bases del curso anterior, que realmente fue MUY básico.

Uff esta clase estuvo muy poco clara.

No desesperen es fácil

  1. entren al cli del router 2
  2. coloquen enable
  3. despues confg
  4. ahí sigan el paso a paso lo que dice la profesora pueden copiar y pegar los comandos de la pagina, no se dejen abrumar por lo demás que le aparece a la profesora, solo digiten los comandos que ella muestra en pantalla
  5. Después entren a la cli del router 0 y coloquen no access-list 101
  6. y listo

muy pobre y muy adelantada la explicación de NAT, configurar el protocolo en packet tracer es fácil (Escribirlo es sencillo), entender el comportamiento del protocolo es lo bello de esto y la llave para configurarlo, porque así se entiende el comportamiento del mismo y porque funciona. pienso que para poder dar esta clase se tiene que haber dado por lo menos Access list para entender el porque se debe crear una.

Por favor, más cursos de redes o una ruta dedicada a ello.

En la NAT existen varios tipos de funcionamiento:

  • Estática: Una dirección IP privada se traduce siempre en una misma dirección IP pública. Este modo de funcionamiento permitiría a un host dentro de la red ser visible desde Internet.
    .
  • Dinámica: El router tiene asignadas varias direcciones IP públicas, de modo que cada dirección IP privada se mapea usando una de las direcciones IP públicas que el router tiene asignadas, de modo que a cada dirección IP privada le corresponde al menos una dirección IP pública.
    .
    Cada vez que un host requiera una conexión a Internet, el router le asignará una dirección IP pública que no esté siendo utilizada. En esta ocasión se aumenta la seguridad ya que dificulta que un host externo ingrese a la red ya que las direcciones IP públicas van cambiando.

.

  • Sobrecarga: La NAT con sobrecarga o PAT (Port Address Translation) es el más común de todos los tipos, ya que es el utilizado en los hogares. Se pueden mapear múltiples direcciones IP privadas a través de una dirección IP pública, con lo que evitamos contratar más de una dirección IP pública. Además del ahorro económico, también se ahorran direcciones IPv4, ya que aunque la subred tenga muchas máquinas, todas salen a Internet a través de una misma dirección IP pública.
    .
    Para poder hacer esto el router hace uso de los puertos. En los protocolos TCP y UDP se disponen de 65.536 puertos para establecer conexiones. De modo que cuando una máquina quiere establecer una conexión, el router guarda su IP privada y el puerto de origen y los asocia a la IP pública y un puerto al azar. Cuando llega información a este puerto elegido al azar, el router comprueba la tabla y lo reenvía a la IP privada y puerto que correspondan.

Que falta de estructura logica en esta clase, no existe una estrucutra detallada, parece que saltara de un curso a otro, muy mal para Platzi

Hasta el momento, esta ha sido la única maestra que no sabe dar los cursos. Pésima maestra, buen contenido

Los que nunca han configurado un router cisco o huawei, en esta clase, quedan perdidos.

falta bastante explicacion, para lo que no tenemos conocimiemnto en el tema sin embargo por aportes de algunos estudiantes y luego de un buen rato investigando logre configurar el router 2 y el 0 ca los aportes de algunos
https://www.youtube.com/watch?v=SD3e7cLgxEg&list=PLYAyQauAPx8niwPYnDOFynhmHiQlXlG5K&index=11

Si tampoco tuviste conexión desde la pc0 al servidor.
Intenten usar el siguiente comando en el Router0 :

Muy interesante

en mi caso no sirve el PT, mi PC-PT PC0 no ve la web

Malísima clase, ojalá la cambien pronto...
Para aquellos que no saben usar o quieren tener una introducción de Cisco Packet Tracer, le dejo un curso corto de la misma plataforma <https://skillsforall.com/es/course/getting-started-cisco-packet-tracer?courseLang=es-XL> Totalmente GRATIS!!
Me frustró bastante esta clase, ya que pasamos de escribir números binarios en una tabla a levantar todo el esquema de una red, el cual particularmente no me funcionó al hacer la prueba entre el cliente y el servidor. Me parece que hay conceptos como nat pool que debería profundizar, una clase previa de packet tracer para crear el esquema y poder configurarlo a mano en vez de solo descargar el modelo, sin tener mucha idea de lo que estoy haciendo y viendo (habiendo realizado el curso anterior)

Hola, el slide del secundo 0:28 esta buenisimo, serian tan amables de compartirlo, Gracias…

ojoala que despues nos puedan compartir el video mas organizado, con las direcciones de cada maquina en un listado de forma explicita y escrita si es red interna o externa, pero todo lo demas esta excelente muchas gracias...
En el material de estudio del curso se encuentra este documento que puede servir a las personas que son nuevas en CCNA <https://study-ccna.com/dynamic-nat/>
La verdad me parece que para ver esta clase toca hacer el curso antes, el que dan en la pagina donde se descarga este software.
Me gustaría que hicieran otro curso de este mismo tema. Fue horrible esta clase. No se entendió nada
Malísima clase, ojalá la cambien pronto...
Alguien tiene algún curso sobre como usar Packet Tracer, ya que en el curso no se da ningun contexto ni nada
Aquí está una configuración básica de una red <https://www.youtube.com/watch?v=bPxtzWPGn-Q>
<https://www.youtube.com/watch?v=3N3e3wC1-pg> Si no tenían idea de PT como yo, aquí lo pueden conocer desde cero, todo lo que faltó explicar en estas clases...
Soy profesional en redes y DevOps, y apesar de que conozco packet tracer y estoy acostumbrado a trabajarlo, vengo siguiendo en orden la ruta de seguridad informatica, y en ningun momento se explico muchos de los conceptos necesarios para esta clase. Para quien quiera aprender a manejar Packet Tracer y entender mejor esta clase les recomiendo tomar el curso de instroduccion. packet tracer propocionado por Cisco: <https://skillsforall.com/course/getting-started-cisco-packet-tracer?courseLang=en-US> Se deben registrar y pasado un tiempo Cisco aprueba el acceso a los cursos. Espero les sirva (Esta en varios idiomas)

Del curso básico a éste curso hay un abismo de información no expuesta. Una vez más saltando a otras plataformas de acceso gratuito porque la información proporcionada por la que pagué una suscripción es insuficiente e imprecisa. Lo que encontré en YouTube mejor explicado https://www.youtube.com/watch?v=7LBr153MH7c&list=PLV2our4ryD2qT35CQXlCBuqOwuw0dOZ5G&index=2

si alguien más tiene problemas descargando los archivos por la nueva actualización de platzi les sugiero usar la aplicación móvil para obtenerlos, subirlos a alguna nube y de ahí pasarlos al PC

Parece que se hubieran saltado varios videos en el curso 😐

para ver la configuración desde la CLI pueden usar el comando show running-config

IMPOSIBLE LLEGAR HASTA AQUI. NO PUDE CONECTAR POR NADA EN EL MUNDO EL PING DESDE LA MAQUINA LOCAL AL SERVIDOR.

hasta este punto pude seguirle sin problemas

Tuve varios problemas con esta clase, comenzando con que no tenía conocimiento de Cisco Packet Tracer, hasta que la profe avanza muy rápido y da varias cosas “por sabidas”. Entonces fui al queridisimo amigo youtube, y desp de mirar varios tutoriales del programa y entender realmente que es el NAT Dinamico (utilizado en esta clase) encontré este video que quizá ahorre mucho tiempo
https://www.youtube.com/watch?v=Ir8ccfaeMro
dura 8:45, es bastante conciso y te permite seguir con la clase

Al final es muy necesario realizar también el curso de CISCO.
Bajo esta logística e ingeniería debemos tener ideas fudamentales que no fueron argumentadas de forma previa.

Es cierto esta parte debió ser mejor detallada

Pesimo, no tengo ni idea lo que dice la docente.

Compañeros aqui les dejo un link sobre introducción redes desde cero, por si gustan chocarle: https://www.youtube.com/watch?v=o-Apbhfnukw&ab_channel=NetworkingPeruano

la verdad, con esta clase perdí todas las ganas de continuar con el curso.

Quiero dar mi opinión pero es una clase AVANZADA de redes, en mi posición entiendo todo, realmente estoy tomando un repaso.

Por aca me perdi con lo del router virtualizado, para quienes quieran probar otra herramienta les recomiendo GNS3, es demasiado buena

Espero que no pregunten nada de esta clase en el examen…

logre instalar packe tracer. Aunque quede un poco perdido en el camino de esta clase.

la imagen de windows 10 es un poco pesada 😃

Un tema demasiado interesante, pero no pude configurar el router 2 me perdi total…

Hice todos los pasos y no puedo llegar a la pagina web

no esta funcionando el acceso a platzi…☺

No pude ver el ejercicio en Packet Tracer.

Descargado e Instalado Packet Tracer :D