Hola, Apple

1

Hablemos de iOS

2

Conozcamos XCode

3

驴Necesito un iPhone para ser iOS Developer?

Tu primera app en iOS

4

隆Hola, Mundo Apple!

5

Navegaci贸n con UINavigationController

6

Modales en la navegaci贸n

7

Utilizando controles en c贸digo

8

Autolayout vs SwiftUI

9

Autolayout

10

Listas con UITableView

11

Celdas personalizadas para nuestras listas.

12

Persistencia: UserDefaults

Manejo de dependencias

13

CocoaPods

14

Carthage

Servicios Web

15

Primeros pasos para consumir servicios

16

Afinando detalles para consumir servicios

17

Convirtiendo los JSON a modelos

18

Alamofire

Proyecto: PlatziTweets

19

Bienvenido a PlatziTweets

20

Configurando Proyecto

21

Dise帽ando vistas iniciales

22

Configuraci贸n de vistas iniciales

23

Configuraci贸n de registro

24

Descripci贸n de la API de PlatziTweets

25

Conexi贸n de la API y Autenticaci贸n

26

Registro de usuarios

27

Dise帽o del Tweet

28

Obteniendo Tweets

29

Creaci贸n de vista para publicar Tweets

30

Publicando Tweets

31

Borrando Tweets

32

Integraci贸n de la c谩mara

33

Conexi贸n con Firebase

34

Configuraci贸n de XCode para correr app

35

Subir imagen a Firebase

36

Publicar Tweet con imagen

37

Tomando Videos para el Tweet

38

Publicar Tweet con video

39

Detalles del video

40

Accediendo al GPS

41

Implementando mapas con MapsKit

42

Mostrando todos los estudiantes en el mapa

43

Retos del proyecto

En producci贸n

44

Enviar a pruebas con Firebase Distribution

45

Enviar tu aplicaci贸n a APP Store Connect

46

Distribuci贸n de tu app con TestFlight

iOS Avanzado

47

Dark Mode

48

SwiftUI

49

Terminando detalles de una vista con SwiftUI

50

Objective-C

Hola, iOS Developer

51

Felicidades

52

Expert Session: 隆nuevo espacio para resolver tus dudas sobre el desarrollo de Apps para iOS!

No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

CocoaPods

13/52
Recursos

Aportes 17

Preguntas 2

Ordenar por:

Los aportes, preguntas y respuestas son vitales para aprender en comunidad. Reg铆strate o inicia sesi贸n para participar.

pod init

pod install

pod update 馃槑

Para los que tenga una macOs Big Sur con procesador MacBook Air (M1,2020) y tenga error al intentar correr el comando pod install en sus maquinas, primero en la tarminal ejecuta

  • sudo arch -x86_64 gem install ffi
    y despu茅s en la terminal pero accediendo al directorio donde esta creado su proyecto ejecute
  • arch -x86_64 pod install

existe algun problema de compatibilidad de este procesador, no es solo con xcode es con varios programas de desarrollo.

Una vez el proyecto usa cocoapods usar el archivo de extensi贸n .xcworkspace para abrir el proyecto en xcode.

pod init
pod install
pod update

sudo gem install cocoapods
cd directorioProyecto/
ls (listar directorios y archivos del proyecto)
**pod init ** (s贸lo la primera vez para crear el archivo)
**pod install **
pod update

Me marca un error al intentar instalar el cocoapods
me dice Error: Failed to build gem native extensions

extconf failed, exit code 1
como lo puedo solucionar para correr lo que proponen en la clase

Am茅 esta clase! vengo del curso anterior de IOS en donde explican esto mismo, pero la verdad all谩 no se entendi贸 y casi nadie pudo correr el proyecto鈥 Con esta clase todo qued贸 claro sobre este tema!

:'( yo en mi primera instalaci贸n de cocoapods tuve problemas con ruby... fue horrible.

De ahora en m谩s debemos abrir siempre el 鈥.xcworkspace鈥

Yo no pude con MBP 2020 M1 Monterrey, no pude con todos los links, encontr茅 este en internet https://medium.com/@staceypyee/installing-cocoapods-on-m1-macbook-air-big-sur-fefccd23f701 y parece que con homebrew si pude鈥

Linck de popup dialog

ME SALE ERROR DEL ASSETES.XCASSETS AL ABRIR EL NUEVO DOCUMENTO workspace, como puedo solucionar este error?

En donde puedo encontrar mas librer铆as para los proyectos de xcode?

Si alguien tiene problemas con pod install en Mac M1, esto funciona muy bien:CocoaPods M1

por alguna raz贸n intentaba en varias ocaciones y la consola me botaba error busque mucho hasta que encontr茅 que la version de ruby tenia que estar actualizada por si a alguien le ocurre lo mismo