A煤n no tienes acceso a esta clase

Crea una cuenta y contin煤a viendo este curso

Preparaci贸n del proyecto en entorno de desarrollo local y agregar mejoras a nuestro proyecto

9/17
Recursos

Aportes 16

Preguntas 11

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad? Crea una cuenta o inicia sesi贸n.

Si al levantar el entorno de desarrollo les sale el error ValidationError: Invalid options object. Watch Ignore Plugin has been initialized using an options object that does not match the API schema., deben modificar el archivo next.config.js de esta forma:

// ...

module.exports = {
    ...,
    webpack: (config, { webpack }) => {
        // ...

	// antes
        // config.plugins.push(new webpack.WatchIgnorePlugin([[/\/content\//]]));
        
	// ahora
	config.plugins.push(new webpack.WatchIgnorePlugin({ paths: [/\/content\//] }));

        return config;
    }
};

Todo est谩 en la forma en c贸mo instanciamos WatchIgnorePlugin. M谩s info aqu铆.

Los errores son nuestros amigos :3

A m铆 no me di贸 error.

$ git push origin master
Username for 'https://github.com': USUARIO
Password for 'https://[email protected]':

Introduc铆 mi contrase帽a de GitHub. Pero me sali贸 as铆:

remote: Support for password authentication was removed on August 13, 2021. Please use a personal access token instead.
remote: Please see https://github.blog/2020-12-15-token-authentication-requirements-for-git-operations/ for more information.
fatal: Autenticaci贸n fall贸 para 'https://github.com/USUARIO/REPOSITORIO.git/'

Si te pas贸 lo mismo, te invito a leer este articulo que me ayud贸 a solucionar el problema.
Tienes que generar Token con la autoridad de acceso al repositorio.

鈥楲os errores son nuestros amigos鈥

Cuando hice

$ npm install

me sali贸 as铆:

25 vulnerabilities (8 moderate, 17 high)

y me asust茅. Pero cuando hice

$ npm install --legacy-peer-deps

se elimin贸 las vulnerabilidades:

found 0 vulnerabilities

No estoy segura si ser谩 la mejor forma, pero a m铆 me funcion贸 as铆.
Ojal谩 que esta informaci贸n sirva para algui茅n.

10 vulnerabilities (1 moderate, 9 critical). porque me pasa esto alguna idea

hola me sale el siguiente error .

1 of 1 unhandled error
Server Error
Error: SourcebitDataClient.getData, cache file 鈥楧:\jamslack\wj-solutions-fd79a.sourcebit-nextjs-cache.json鈥 was not found after 10 retries

This error happened while generating the page. Any console logs will be displayed in the terminal window.
Call Stack
Timeout.checkPathExists [as _onTimeout]
file:///D:/jamslack/wj-solutions-fd79a/node_modules/sourcebit-target-next/index.js (365:25)

y en la consola lo suiguiente s and retry #9
SourcebitDataClient.getData, cache file 鈥楧:\jamslack\wj-solutions-fd79a.sourcebit-nextjs-cache.json鈥 not found, waiting 500ms and retry #10
Error: SourcebitDataClient.getData, cache file 鈥楧:\jamslack\wj-solutions-fd79a.sourcebit-nextjs-cache.json鈥 was not found after 10 retries
at Timeout.checkPathExists [as _onTimeout] (D:\jamslack\wj-solutions-fd79a\node_modules\sourcebit-target-next\index.js:365:25) {
type: 鈥楨rror鈥
}
Error: SourcebitDataClient.getData, cache file 鈥楧:\jamslack\wj-solutions-fd79a.sourcebit-nextjs-cache.json鈥 was not found after 10 retries
at Timeout.checkPathExists [as _onTimeout] (D:\jamslack\wj-solutions-fd79a\node_modules\sourcebit-target-next\index.js:365:25) {
type: 鈥楨rror鈥

Me encanta la integraci贸n entre no-code (stackbit) y code desde local los cambios que se pueden realizar son muy r谩pidos y se visualizan realtime en stackbit

No me sali贸 ning煤n error

$ node -v
v14.17.6

$ npm -v
6.14.15

porque no te pide contra al usar git push origin master

PORQUE NO VEO EL [Master] en la terminal

Cuando corran el 鈥渘pm run dev鈥 es posible que a la primera no les salga bien, les recomiendo volver a hacerlo y recuerden: 鈥渓os errores son nuestros amigos no nuestros enemigos鈥.

Error: failed to load next.config.js, see more info here https://nextjs.org/docs/messages/next-config-error
Error: Cannot find module 'lodash'
Require stack:
- /Users/aam/practicaweb/magenta-panda-f26ac/sourcebit.js
- /Users/aam/practicaweb/magenta-panda-f26ac/next.config.js
- /Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/config.js
- /Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/next.js
- /Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/lib/start-server.js
- /Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/cli/next-dev.js
- /Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/bin/next
    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:940:15)
    at Function.mod._resolveFilename (/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/build/webpack/require-hook.js:96:28)
    at Function.Module._load (node:internal/modules/cjs/loader:773:27)
    at Module.require (node:internal/modules/cjs/loader:1012:19)
    at require (node:internal/modules/cjs/helpers:93:18)
    at Object.<anonymous> (/Users/aam/practicaweb/magenta-panda-f26ac/sourcebit.js:1:11)
    at Module._compile (node:internal/modules/cjs/loader:1108:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1137:10)
    at Module.load (node:internal/modules/cjs/loader:988:32)
    at Function.Module._load (node:internal/modules/cjs/loader:828:14) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '/Users/aam/practicaweb/magenta-panda-f26ac/sourcebit.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/next.config.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/config.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/next.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/server/lib/start-server.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/cli/next-dev.js',
    '/Users/aam/practicaweb/magenta-panda-f26ac/node_modules/next/dist/bin/next'
  ]
}

Esto me sale al querer correrlo

(base) [email protected] magenta-panda-f26ac % npm audit fix --force
npm WARN using --force Recommended protections disabled.
npm WARN audit Updating lodash to 11.1.2,which is a SemVer major change.
npm WARN audit Updating next to 11.1.2,which is a SemVer major change.
npm WARN audit Updating sourcebit to 0.6.0,which is a SemVer major change.
npm WARN audit No fix available for [email protected]*
npm WARN audit No fix available for [email protected]*
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react
npm WARN   peer [email protected]">=16" from [email protected]0.6.4
npm WARN   node_modules/sourcebit-target-next
npm WARN     [email protected]"^0.6.2" from the root project
npm WARN   1 more (the root project)
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from [email protected]11.1.2
npm WARN node_modules/next
npm WARN   [email protected]"11.1.2" from the root project
npm WARN   1 more (sourcebit-target-next)
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react-dom
npm WARN   [email protected]"17.0.1" from the root project
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from [email protected]11.1.2
npm WARN node_modules/next
npm WARN   [email protected]"11.1.2" from the root project
npm WARN   1 more (sourcebit-target-next)
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react
npm WARN   peer [email protected]">=16" from [email protected]0.6.4
npm WARN   node_modules/sourcebit-target-next
npm WARN     [email protected]"^0.6.2" from the root project
npm WARN   1 more (the root project)
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from @next/[email protected]11.1.2
npm WARN node_modules/next/node_modules/@next/react-dev-overlay
npm WARN   @next/[email protected]"11.1.2" from [email protected]11.1.2
npm WARN   node_modules/next
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react
npm WARN   peer [email protected]">=16" from [email protected]0.6.4
npm WARN   node_modules/sourcebit-target-next
npm WARN     [email protected]"^0.6.2" from the root project
npm WARN   1 more (the root project)
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from @next/[email protected]11.1.2
npm WARN node_modules/next/node_modules/@next/react-dev-overlay
npm WARN   @next/[email protected]"11.1.2" from [email protected]11.1.2
npm WARN   node_modules/next
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react-dom
npm WARN   [email protected]"17.0.1" from the root project
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from @next/[email protected]11.1.2
npm WARN node_modules/next/node_modules/@next/react-dev-overlay
npm WARN   @next/[email protected]"11.1.2" from [email protected]11.1.2
npm WARN   node_modules/next
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: [email protected]17.0.1
npm WARN node_modules/react-dom
npm WARN   [email protected]"17.0.1" from the root project
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer [email protected]"^17.0.2" from @next/[email protected]11.1.2
npm WARN node_modules/next/node_modules/@next/react-dev-overlay
npm WARN   @next/[email protected]"11.1.2" from [email protected]11.1.2
npm WARN   node_modules/next
npm ERR! Cannot read property 'version' of undefined

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/aam/.npm/_logs/2021-10-07T18_09_24_909Z-debug.log

Alguna explicacion??

me descargue otra plantilla con el mismo stack pero el archivo index no tiene las partes de excerpt ni date, y el layout dice advanced, esta mal eso?