No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

F贸rmulas condicionales

12/22
Recursos

Aportes 193

Preguntas 27

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad?

Esta son las formulas que utilic茅, adem谩s use lo aprendido en las clases pasadas para hacer una grafica din谩mica que muestre el porcentaje de participaci贸n de cada plataforma por seg煤n el pa铆s

nos sabia lo de F4 馃榾

Las F贸rmulas Condicionales son muy 煤tiles cuando se necesita poner alguna condici贸n para obtener alg煤n valor y/o resultado.
Algunas Funciones a tener en cuenta:

  • MES(A2): toma una celda con formato fecha y saca el mes de este arrojando el n煤mero del mes, esto es, enero 1, marzo 3.

  • TEXTO(A2;鈥淢MMM鈥): toma una celda con formato fecha y saca el nombre del mes de dicha fecha.

  • TEXTO(A2;鈥淒DDD鈥): toma una celda con formato fecha y saca el nombre del d铆a de la semana de dicha fecha.

  • SUMAR. SI: funci贸n para sumar con una condici贸n.

  • SUMAR.SI.CONJUNTO: funci贸n para sumar con m谩s de una condici贸n, es decir, 2 o m谩s condiciones.

  • CONTAR. SI: funci贸n para contar con una condici贸n.

  • CONTAR.SI.CONJUNTO: funci贸n para contar con m谩s de una condici贸n, es decir, 2 o m谩s condiciones.

El ejercicio es de la Clase de Buscar V

Tuve varios errores, pero ya por fin lo consegu铆 馃槂

Algo para aclarar frente al curso: Una cosa es f贸rmula y otra distinta es funci贸n.

Una funci贸n es una f贸rmula predeterminada de Excel, la cual tiene un orden o sintaxis que nos lleva a cumplir con algunos par谩metros fijos y otros opcionales.

Una f贸rmula como tal es cualquier operaci贸n matem谩tica que podemos realizar en excel para llegar a un resultado.

Dado lo anterior, est谩 explicando es funciones condicionales, no f贸rmulas.

As铆 mismo, no se explican ejemplos con operadores de comparaci贸n, los cuales podemos usar con funciones condicionales y/o funciones l贸gicas:

= igual

mayor que
= mayor igual que
< menor que
<= menor igual que
<> diferente de

El ejercicio de tarea es incorrecto, no es el de la clase de f贸rmulas condicionales.

Recuerden siempre el uso de fijaci贸n de celdas lo pueden hacer con F4 por ejemplo $C$5 lo que hace es fijar la columna c y la fila de la celda 5 pero si ponemos C$5 van a fijar la celda 5 y esta no se mover谩. con F4 presionando varias veces ver谩n que pueden tener los dos d贸lares que fijan columna y fila de la celda si presionas otra vez solo un d贸lar que fija la celda de la fila y si presionas de nuevo fija la celda de la columna.

He agregado formato de color a las celdas de Amazon Prime con la condici贸n <=5% para comparar con el resultado de las condiciones.

Aqui esta mi ejercicio de f贸rmulas condicionales


Comparto las f贸rmulas que utilic茅:

=SUMA(SUMAR.SI(Tabla1[[#Todo],[Pa铆s]],F7,Tabla1[[#Todo],[Netflix]]),SUMAR.SI(Tabla1[[#Todo],[Pa铆s]],F7,Tabla1[[#Todo],[HBO]]))

y

=CONTAR.SI(Tabla1[[#Todo],[Amazon Prime]],"<5%")

**My results!! **

Aqu铆 un breve an谩lisis de la hoja Ventas.

  • El mes con mayores ventas fue Mayo con $133.206 seguido de Enero con $123.191. El mes con menor venta fue Febrero con $110.688.

  • De enero a mayo, el d铆a con mayores ventas fue el s谩bado seguido del lunes. El d铆a con menores ventas fue el domingo.

El ejercicio puesto aqu铆 no es de la clase

Lo logre 馃槃

El ejercicio en la secci贸n de recursos no pertenece a la clase de formulas condicionales.

Siento incompleto este curso, dejan al estudiante a la deriva y nadie te ayuda, me toca buscar en YouTube ejercicios donde expliquen e ir haciendolos.


No se si sea el metodo adecuado, pero para el ejercicio utilice esta forma:

- % B煤squedas de Netflix y HBO en Per煤: =SUMAR.SI(H4:H13;D5;I4:I13)+SUMAR.SI(H4:H13;D5;J4:J13)

- Numero de paises con busquedas en amazon prime de 5% o Menos =CONTAR.SI(L5:L13;"<=5%")

Una tabla adicional que realic茅 para luego analizarla con gr谩ficos din谩micos.

EL ejercicio corresponde a la lecci贸n de BUSCARV

Hola a todos, estos son mis resultados: ![]()![](https://static.platzi.com/media/user_upload/image-b55caa08-76e8-4106-a652-765a631c3e45.jpg)
![](https://static.platzi.com/media/user_upload/image-74339f28-f46b-40cb-ab5d-80d2d1771f52.jpg)
![](https://static.platzi.com/media/user_upload/image-80db525a-e2c7-4a3b-ba7c-7c291f4be691.jpg)Muy buenos aportes Tkns
quede insatisfecho con la clase lastima !


Comparto lo aprendido en clase, realic茅 2 gr谩ficos:

  1. Gr谩fico circular: con el fin de analizar pa铆s por pa铆s.
  2. Barras: para tener un pantallazo de % de participaci贸n en cada pa铆s.

Saludos!

Comparto mis soluciones amigos, Para sumar el % de busquedas de Netflix y HBO en Peru puede hacerlo con SUMAR.SI.CONJUNTO y SUMAR.SI, siento que no se utilzar del todo el SUMAR.SI.CONJUNTO ya que lo tuve q sumar por separado ![](https://static.platzi.com/media/user_upload/image-9c2b7bcf-5b00-4f47-b295-fd85812c8921.jpg)


Batall茅 mucho para sacar el resultado del ejercicio de excel, es 74% de Per煤, pero en cuanto al otro ejercicio no me sal铆a ninguna formula, me aparece como un mensaje de error,como si no reconociece la f贸rmula, si no es mucha molestia alguien podr铆a ayudarme?

Les comparto mi ejercicio:

=SUM(SUMIF(H5:H13,G4,I5:I13),SUMIF(H5:H13,G4,J5:J13))

=COUNTIF(L5:L13,"<0.05")

No logr茅 hacerlo con buscar.si.conjunto

驴Alguna ayuda? c:

Es incre铆ble como se puede acelerando el proceso aplicando los conocimientos de clases anteriores para hacer los ejercicios y que se vean m谩s profesionales, se est谩n notando los resultados

Adjunto ejercicio utilizando la funcion BUSCARV en lo personal es una de las mas utiles鈥 porque te permite encontrar algun dato que por la densidad del archivo a ojo te tomaria un monton de tiempo, por otro lado esta herramienta la he utilizado para estandarizar diferentes fuentes de datos para la creacion de estadisticas empresariales.

Esto es hacer programaci贸n en excel.

Aunque no es el ejercicio de la clase, dejo resuelto el ejercicio que dejaron en los RECURSOS con laf贸rmula de Buscarv que es ingl茅s es VLOOKUP. Me cost贸 al principio resolverlo, pero leyendo los par谩metros pude encontrar la soluci贸n.

El ejercicio es sobre buscarv, pero a煤n as铆 lo hice. Espero puedan corregir el error.

Mi soluci贸n

Mi resultado: ![](https://static.platzi.com/media/user_upload/image-733b27bf-fc99-4f3c-a57f-6a6cc3e206d1.jpg)
![]()![](< RESULTADO FORMULA USADA Porcentaje de b煤squedas de Netflix y HBO de Per煤 74% SUMAR.SI.CONJUNTO(I4:I13;H4:H13;H7)+(SUMAR.SI.CONJUNTO(J4:J13;H4:H13;H7)) N煤mero de pa铆ses con b煤squedas de Amaz贸n Prime de 5% o menos 3,00 CONTAR.SI(L4:L13;"\<=5%")>)
![](https://static.platzi.com/media/user_upload/image-1db273db-c9d2-46df-b3a3-9b4d39777fff.jpg)
Tengo un Excel un poco viejo creer铆a que la clase deber铆a tener algunos par茅ntesis para explicar cosas que no podemos hacer en este Excel avanzado por lo menos explicar la relaci贸n ya que el entendimiento del 谩rea fue nulo me toco buscar ayuda por otros medios.
![](https://static.platzi.com/media/user_upload/image-7cb0841f-811c-41f6-ab84-174060696713.jpg)
Mi humilde solucion Punto 1 `=PROMEDIO((SUMAR.SI($H$5:$H$13;H7;I5:I13));(SUMAR.SI($H$5:$H$13;H7;J5:J13)))` Punto 2 `=CONTAR.SI(L5:L13;"<=5%")`
### **Estructura b谩sica de las f贸rmulas condicionales** * Las f贸rmulas condicionales comienzan con un "si" de condici贸n, seguido de la prueba l贸gica y los valores si es verdadera la condici贸n y si es falsa. ### **Comparaci贸n de fechas** * Podemos comparar fechas utilizando la funci贸n "SI" y una condici贸n l贸gica. * Ejemplo: "SI(A2=A3-1,1,0)" nos permite verificar si las fechas son consecutivas. ### **Funci贸n "SUMAR.SI" para sumar valores seg煤n una condici贸n** * Utilizamos "SUMAR.SI" para sumar valores si se cumple una condici贸n espec铆fica. * Sintaxis: SUMAR.SI(rango, criterio, \[sumar\_rango]) * rango: El rango donde se evaluar谩 el criterio. * criterio: La condici贸n que debe cumplir la celda en el rango. * sumar\_rango (opcional): El rango que contiene los valores a sumar. * Ejemplo: SUMAR.SI(B:B,J2,C:C) suma las ventas totales para un mes espec铆fico. ### **Funci贸n "SUMAR.SI.CONJUNTO" para sumar con m煤ltiples condiciones** * "SUMAR.SI.CONJUNTO" nos permite sumar valores con m煤ltiples condiciones. * Sintaxis: SUMAR.SI.CONJUNTO(sumar\_rango, criterio1, rango1, \[criterio2, rango2], ...) * sumar\_rango: El rango que contiene los valores a sumar. * criterio1, criterio2, etc.: Las condiciones que deben cumplir las celdas en los rangos respectivos. * rango1, rango2, etc.: Los rangos donde se evaluar谩n los criterios. * Ejemplo: SUMAR.SI.CONJUNTO(D:D,B:B,K2,C:C,L2) suma ventas totales para un d铆a de la semana y un mes determinado. ### **Funci贸n "PROMEDIO.SI.CONJUNTO" para calcular el promedio con condiciones** * Similar a "SUMAR.SI.CONJUNTO", "PROMEDIO.SI.CONJUNTO" calcula promedios con m煤ltiples condiciones. * Sintaxis: PROMEDIO.SI.CONJUNTO(promedio\_rango, criterio1, rango1, \[criterio2, rango2], ...) * promedio\_rango: El rango que contiene los valores para calcular el promedio. * criterio1, criterio2, etc.: Las condiciones que deben cumplir las celdas en los rangos respectivos. * rango1, rango2, etc.: Los rangos donde se evaluar谩n los criterios. ### **Manejo de errores con "SI.ERROR"** * "SI.ERROR" nos permite personalizar la respuesta ante un error en una f贸rmula. * Sintaxis: SI.ERROR(valor, valor\_si\_error) * valor: La expresi贸n o f贸rmula que se evaluar谩. * valor\_si\_error: El valor que se mostrar谩 si se produce un error en la evaluaci贸n. * Ejemplo: SI.ERROR(f贸rmula, "Error") muestra "Error" en lugar de un valor de error.
![](https://static.platzi.com/media/user_upload/image-86cfaaab-1a1c-4e78-94d5-b81e97ae0f1c.jpg)
Buenos d铆as ![](https://static.platzi.com/media/user_upload/image-8a6faa28-cd77-41db-ba24-0ab12d236b41.jpg) ![](https://static.platzi.com/media/user_upload/image-2e6faa27-fc52-464b-8f72-6240c8ae587a.jpg)
Me pareci贸 m谩s apropiado/pr谩ctico resolver la primera pregunta con Buscar V: ```js =SUMA(BUSCARV(E7;E5:I13;2;0);BUSCARV(E7;E5:I13;3;0)) ```=SUMA(BUSCARV(E7;E5:I13;2;0);BUSCARV(E7;E5:I13;3;0)) El resultado es 74% Y la segunda: ```js =CONTAR.SI.CONJUNTO(I5:I13;"<=5%") ```Respuesta es 3
![](https://static.platzi.com/media/user_upload/image-c1848e23-bc00-4410-8411-f52caa9c78a2.jpg)
Datos de entrada del Ejercicio: ![](https://static.platzi.com/media/user_upload/image-2b909e6b-168a-4ac7-93ca-8ec7cfb7018c.jpg) Resultado: Ordenar los Paises con funci贸n ORDENAR y luego validacion a dicho cellda del pais con referencia matricial. Dos validacion para los dos servicios. Utilizar funici贸n BUSCARX una unica formula con referencia mixtas en calculo del porcentanje. Un gr谩fico dinamico de Columnas Y por 煤ltimo para no complicar funci贸n CONTAR.SI.CONJUNTO para la cantidad menores al 5% en Amazon Prime. RESULTADO: ![](https://static.platzi.com/media/user_upload/image-65062782-9a2f-4b01-956c-114971cf7393.jpg)
![](https://static.platzi.com/media/user_upload/image-b2f1772e-6059-4d22-913f-f03411916a87.jpg)
![](https://static.platzi.com/media/user_upload/image-a4b46136-0339-4313-a369-03a21dbaac47.jpg)
![](https://static.platzi.com/media/user_upload/image-7c4e7695-6104-4de5-8e90-74d3a43a2041.jpg)
![](https://static.platzi.com/media/user_upload/image-dce8694a-b9f8-4575-8eb7-35176287469a.jpg) ![](https://static.platzi.com/media/user_upload/image-d7db4429-9b23-43d9-8958-a78a95357656.jpg)
Que tal todos, les dejo mi ejercicio. ![](https://static.platzi.com/media/user_upload/image-f510bff8-1124-42b4-bf81-a4e513816b38.jpg)
He subido l ejercicio varias veces pero no los deja Registrar y en otro casos lo registra a nombre de otra persona.. ![](https://static.platzi.com/media/user_upload/image-23f890d9-e78e-4b10-a0f3-883604e01b6a.jpg)
![](https://static.platzi.com/media/user_upload/image-bd3f815d-7aec-4491-8e2f-05f2daca7d83.jpg)
Ejercicio Condicionales. ![](https://static.platzi.com/media/user_upload/image-91dc5b24-cb52-4a72-acce-d8a5609f8670.jpg)
EJERCICO CON FORMULAS CONDICIONALES. ![](https://static.platzi.com/media/user_upload/image-429222b3-c095-4b73-b96f-e7e128095e98.jpg)
EJERCICIO CON FORMULAS CONDICIONALES. ![](https://static.platzi.com/media/user_upload/image-dbbef507-723c-41dc-ba53-ccd8da967420.jpg)
C贸mo hacen para que les salga este cuadro? Veo que la mayor铆a que publica su respuesta lo usa. Es algo que sale autom谩tico o tengo que seleccionar? ![](https://static.platzi.com/media/user_upload/image-dd4e8e35-f8cc-4d26-a14f-74ca4cf602d0.jpg)

![](

Para poder tener el nombre del mes como: enero, febreto, marzo etc. esta es la formula que se necesita. **=TEXT(A2,"mmmm")** (en A2 esta la fecha que queremos usar)
Utilic茅 las formulas: \=SUMAR.SI.CONJUNTO(Tabla1\[\[#Todo];\[Netflix]];Tabla1\[\[#Todo];\[Pa铆s]];"Per煤") \=SUMAR.SI.CONJUNTO(Tabla1\[\[#Todo];\[HBO]];Tabla1\[\[#Todo];\[Pa铆s]];"Per煤") \=C6+D6 \=CONTAR.SI(Tabla1\[Amazon Prime];"<=5%") ![](https://static.platzi.com/media/user_upload/image-9ff1a007-f561-4122-a4a7-b9cafa70bb80.jpg)
![](https://static.platzi.com/media/user_upload/image-e3966f61-22c5-4f46-8484-21a48ec9438b.jpg)
Un aporte peque帽o pero que puede ser util. Hay dos formas de colocar la condici贸n en la funcion CONTAR.SI.CONJUNTO: La primera es colocar la condicion dentro la funci贸n de la siguiente forma: =CONTAR.SI.CONJUNTO(rango\_de\_datos,"<=5%") IMPORTANTE! Escribir la condicion dentro de las comillas "", de lo contrario la formula no funciona. La segunda opcion es colocar la condicion en una celda aparte, y desde la funcion llamar la celda donde colocamos la condicion: \=CONTAR.SI.CONJUNTO(rango\_de\_datos,E4) Donde E4 es la celda donde se encuentra escrita la condicion en este caso <=5% Saludos!!
![](https://static.platzi.com/media/user_upload/image-64dc1aec-dd76-489a-ac59-194affe857a9.jpg)
Una gran herramienta para entender mejor el comportamiento de los casos, por ejemplo en este gr谩fico din谩mico se logra apreciar claramente la relaci贸n inversa entre la utilidad y el costo, es decir: a medida que disminuyo costo aumento mi utilidad![](https://static.platzi.com/media/user_upload/image-93e1d6c0-55f6-4f00-a85a-f812c8ed2eda.jpg)
![](https://static.platzi.com/media/user_upload/image-f47dbfa7-e0da-49bc-9d34-8c6db9ab0aa0.jpg)
![](https://static.platzi.com/media/user_upload/image-0b248d04-985d-4126-a57b-3486d6e452df.jpg)
![](https://static.platzi.com/media/user_upload/image-3a9aa717-412e-4c78-8c54-788b1ec87a9d.jpg)
Hola, yo lo realice con las siguientes f贸rmulas: \=SUMAR.SI(H5:H13;"Per煤";I5:I13)+SUMAR.SI(H5:H13;"Per煤";J5:J13) ya que deb铆a tener en cuenta el criterio 2 del pa铆s dos veces. Y, =CONTAR.SI.CONJUNTO(L5:L13;"<=5%")
Hola les comparto las formulas que use para resolver el ejercicio 馃 gracias por la clase ![](https://static.platzi.com/media/user_upload/Captura%20de%20pantalla%202024-01-02%20a%20la%28s%29%2018.17.08-2beba33d-a5f3-4c30-b914-a5502a4eed4c.jpg)
![](https://static.platzi.com/media/user_upload/image-8254d43c-94cc-4778-8968-3a3f9e30d748.jpg)
![](https://static.platzi.com/media/user_upload/image-5f2b4e41-fb99-46d7-a4d6-61ee71294bc7.jpg)
En mi excel no aparece la formula de sumar.si.conjunto
Respuesta ejercicio 2![](https://static.platzi.com/media/user_upload/image-8f316ff8-3af7-45d7-94dd-92918850e4ae.jpg)
Respuesta ejercicio 1 ![](https://static.platzi.com/media/user_upload/image-30e6024f-fd4b-4b59-9eb6-6a548b138743.jpg)

En realidad al no solicitarme el uso de tablas dinamicas ni graficos, sino el uso funciones l贸gicas. para la respuesta concreta, lo realic茅 de este modo, simplemente para la pr谩ctica de estas funciones

Porcentajes de b煤squedas de Netflix y HBO en per煤:
.
HBO

.
NETFLIX

.
N煤mero de pa铆ses con b煤squedas de Amaz贸n Prime de 5% o menos

![](https://static.platzi.com/media/user_upload/image-efc55f72-2be3-4e9b-99e4-0b554fd57143.jpg)
![](https://static.platzi.com/media/user_upload/image-ebb2c2ce-b9da-4afe-9904-b7883fc060a3.jpg)
![](https://static.platzi.com/media/user_upload/image-d2a33b59-921e-46b0-af59-be316cea079b.jpg)

Ejercicio

ejercicio ![](https://static.platzi.com/media/user_upload/image-86888227-8c92-4333-b4f6-2923f08db7e4.jpg)
![](https://static.platzi.com/media/user_upload/image-95017940-589a-4cf8-ab06-9beacfd2f785.jpg)
![](https://static.platzi.com/media/user_upload/image-a8f049c5-e5a6-429e-933c-08cad4fb9fe8.jpg)

Aprendiendo mucho, buena practica y clase.

Mi ejercicio de la clase

```js ```![]()![](https://static.platzi.com/media/user_upload/image-5f5f1a9a-fe94-4294-8494-205bd2df8217.jpg)![](https://static.platzi.com/media/user_upload/image-2c6d7327-a1f6-4350-a71f-8b28e69f71a6.jpg) ```js ```

Con lo que aprendimos en la clase de Data Validation podemos crear un men煤 desplegable para la casilla Dia de la Semana

No agrego imagen porque no me funciona esa opci贸n @PlatziTeam

Alguien sabe como puedo descargar el archivo de excel ? en la opci贸n de recursos no me aparece muchas gracias

Aprovech茅 para hacer una lista desplegable con la lista de los pa铆ses y vincular la celda de la lista a la formula para que arrastre los valores, de los dem谩s pa铆ses.

Este es el resultado.

Buenas, dejo mis ejercicios.

Gran aporte gracias

Un poco dif铆cil de generar tablas y gr谩ficos din谩micos combinados con las funciones condicionales.