No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

BuscarV y BuscarH

13/22
Recursos

Aportes 234

Preguntas 6

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad?

Recuerden que depende el formato de entrada deber谩n usar 鈥渃oma鈥 o 鈥減unto y coma鈥. Al desplegar la funci贸n, la barra de ejemplo muestra con cual deber铆a ser, seg煤n el caso.

La funci贸n BUSCARX es la versi贸n mejorada de BUSCARV, permite buscar sin tener la limitaci贸n de que el valor buscado este en la primera columna del rango.

(=BUSCARV(B6:B6,busqueda,2,0)
Como detalle, me funciona asignar un nombre con relaci贸n a la din谩mica a toda la tabla. De esta forma no selecciono el rango de datos cada que utilizo la formula.

Dejo captura del ejercicio, agregu茅 a mi Argentina, veo que la decadencia musical nos azota a todos. 馃槫

Son formulas para buscar informaci贸n en la base de datos:

BUSCARV

Use BUSCARV cuando necesite encontrar elementos en una tabla o un rango por fila (b煤squeda vertical). Se estructura de la siguiente manera:

=BUSCARV(J3,B1:H6,2,FALSO)

BUSCARV es la formula a utilizar.

  • En 鈥淛3鈥 en la caso de esta formula es el valor a buscar en la fila.

En 鈥淏1:H6鈥 se coloca la matriz de la tabal donde se buscar谩 la informaci贸n.

En el 鈥2鈥 es el indicador de la columna donde deber谩 buscar el valor que buscamos.

En 鈥淔ALSO鈥 es el rango o criterio que usar谩 para mostrar el valor. En la caso de Verdadero o 鈥1鈥 buscar谩 el valor pr贸ximo y en el caso de Falso o 鈥淥鈥 es para buscar el valor exacto.

BUSCARH

Use BUSCARH cuando los valores de comparaci贸n se encuentren en una fila en la parte superior de una tabla de datos y desee encontrar informaci贸n que se halle dentro de un n煤mero especificado de filas.

=BUSCARH(L2,D1:H6,6,0)

BUSCARH es la formula a utilizar

  • En 鈥淟2鈥 en la caso de esta formula es el valor a buscar en la fila.

En 鈥淒1:H6鈥 se coloca la matriz de la tabal donde se buscar谩 la informaci贸n.

En el 鈥6鈥 es el indicador de la columna donde deber谩 buscar el valor que buscamos.

En 鈥0鈥 es el rango o criterio que usar谩 para mostrar el valor. En la caso de Verdadero o 鈥1鈥 buscar谩 el valor pr贸ximo y en el caso de Falso o 鈥淥鈥 es para buscar el valor exacto.

Ejercicio pr谩ctico:

F贸rmula % b煤squedas Rosal铆a:
=BUSCARV(B6;I4:K35;2;0)
F贸rmula % b煤squedas Bad Bunny
=BUSCARV(E6;I4:K35;3;0)

Consejo!

Para que sea mas sencillo usar estas funciones, les recomiendo que seleccionemos toda nuestra tabla donde buscaremos la informacion y le asignemos un nombre en el etiquetador de nombre, en la pesta帽a de inicio.

Asi, cuando tengamos que seleccionar el rango de las celdas donde buscaremos el valor, ponemos simplemente el nombre de la tabla y listo!
.

Cuando les aparezca Error #N/A y escribieron la formula bien, vean en valor en buscado si no esta con espacio ya que el espacio lo cuenta tambien, para tenerlo encuenta para ese tipo de errores.

La nueva funci贸n BUSCARX, fue lo mejor que hizo microsoft鈥

Importante aclarar que en las funciones buscarv y buscarh, la b煤squeda siempre debe ser por coincidencia exacta para que busque concretamente lo solicitado y evitar errores frente a celdas en las que parte de la informaci贸n contenida sea similar al valor buscado鈥

Hola a todos,
Mis f贸rmulas lucen as铆, fije la matriz de datos para desplegar la formula con los otros pa铆ses sin que se corriera el rango de selecci贸n.
Saludos

No me gusta que no resuelvan los retos en las clases siguientes a la postulaci贸n del reto

Reto cumplido:
% de b煤squedas Rosal铆a
Venezuela VLOOKUP(B6;$I$4:$K$35;3;0)
Chile VLOOKUP(B7;$I$4:$K$35;3;0)
Colombia VLOOKUP(B8;$I$4:$K$35;3;0)

% de b煤squedas Bad Bunny
Cuba VLOOKUP(E6;$I$4:$K$35;3;0)
Nicaragua VLOOKUP(E7;$I$4:$K$35;3;0)
Bolivia VLOOKUP(E8;$I$4:$K$35;3;0)

Aqu铆 el ejercicio:

F贸rmula Rosal铆a:
=BUSCARV(B6;I4:K35;2;0)

F贸rmula BadBunny:
=BUSCARV(E6;I4:K35;3;0)

*Mi soluci贸n 馃挌* ![](https://static.platzi.com/media/user_upload/image-2fcdc096-289c-434d-a238-6dbd38e82eda.jpg)
![](https://static.platzi.com/media/user_upload/image-70474977-d449-4193-bee2-dc508f918396.jpg)

Para resolver el problema del que habla la profe asigne el valor de Id a buscarH y le sume 1 para que coincida con el vendedor correspondiente.

![](https://static.platzi.com/media/user_upload/image-7293d534-0292-4936-9f96-c7b6930bcd14.jpg)
驴Por que las f贸rmulas BuscarV y BuscarH son las m谩s 煤tiles en Excel?
#### **Uso de la Funci贸n BUSCARV** La funci贸n BUSCARV permite buscar valores en una columna espec铆fica y retornar un valor correspondiente de otra columna en la misma fila. Es ideal para b煤squedas verticales en tablas de datos. 1. **Sintaxis de la Funci贸n BUSCARV:** BUSCARV(valor\_buscado, tabla\_b煤squeda, columna\_valor, \[exacto]) 1. 2. **Argumentos de la Funci贸n:** * valor\_buscado: El valor que se desea encontrar en la primera columna de la tabla. * tabla\_b煤squeda: El rango de celdas que contiene la tabla donde se realizar谩 la b煤squeda. * columna\_valor: El n煤mero de columna en la tabla desde la cual se debe devolver el valor correspondiente. * \[exacto]: Un valor l贸gico (verdadero/falso o 1/0) que especifica si la b煤squeda debe ser exacta o aproximada. #### **Ejemplo de Uso de BUSCARV** Supongamos que queremos encontrar el nombre de un vendedor dado su ID. Utilizamos la funci贸n BUSCARV para realizar esta b煤squeda en una tabla de datos de ventas por vendedor. #### **Uso de la Funci贸n BUSCARH** Por otro lado, la funci贸n BUSCARH realiza b煤squedas horizontales en lugar de verticales. Esto significa que busca un valor en la primera fila de una tabla y devuelve un valor de la misma columna en una fila espec铆fica. 1. **Sintaxis de la Funci贸n BUSCARH:** BUSCARH(valor\_buscado, tabla\_b煤squeda, fila\_valor, \[exacto]) 1. 2. **Argumentos de la Funci贸n:** * valor\_buscado: El valor que se desea encontrar en la primera fila de la tabla. * tabla\_b煤squeda: El rango de celdas que contiene la tabla donde se realizar谩 la b煤squeda. * fila\_valor: El n煤mero de fila en la tabla desde la cual se debe devolver el valor correspondiente. * \[exacto]: Un valor l贸gico (verdadero/falso o 1/0) que especifica si la b煤squeda debe ser exacta o aproximada. #### **Ejemplo de Uso de BUSCARH** Supongamos que queremos encontrar las ventas de un vendedor en un mes espec铆fico. Utilizamos la funci贸n BUSCARH para buscar el mes y luego obtener las ventas correspondientes.
![]()![](https://static.platzi.com/media/user_upload/image-73babc2c-3a63-4183-a6ef-c3b60f6de93a.jpg) ![]()![](https://static.platzi.com/media/user_upload/image-34651db0-be22-4506-84f6-15ea5328cfe9.jpg)
![](https://static.platzi.com/media/user_upload/image-074eb16c-2b3a-44b2-9961-84df9839a700.jpg)HOLA CUANDO SELCCIONO LA TABLA APARECE ASI... AYUDA PLEASE
HOLA, AYUDA... ME APARECE #N/D (TENGO LOS VALORES BIEN)
POR FAVOR NECESITO AYUD, no he podido pasar de las clases 11 y 12, escribir al siguiente numero 3142043517, por favor, siempre que escribo nunca obtengo respuesta de alguien de aca
![](https://static.platzi.com/media/user_upload/image-07d6b130-3985-499d-a980-85cd76d24064.jpg)
![](https://static.platzi.com/media/user_upload/image-1eddb523-6d41-41ef-9e76-b9b656c7ef85.jpg)
Una vez tienes en cuenta los par谩metros es muy f谩cil de utilizar: Primero la referencia del valor que estamos buscando (Pa铆s), luego la tabla donde buscaremos, en qu茅 columna est谩 ubicado dicho valor (muy 煤til cuando solo podemos guiarnos por el nombre de la columna) e indicamos si ser谩 exacta: ![](https://static.platzi.com/media/user_upload/image-b20c2a59-cc3b-4e63-8cca-00fc035fb7ee.jpg)
![](https://static.platzi.com/media/user_upload/image-71f4aaca-14f8-4805-b6e0-268cefdb85ca.jpg)![](https://static.platzi.com/media/user_upload/image-67d35153-4642-4d26-ab92-ed3acada327a.jpg)
![](https://static.platzi.com/media/user_upload/image-6a64dcef-6937-4e28-9e5e-4893fe99219f.jpg)
![]()![]()![](https://static.platzi.com/media/user_upload/Captura%20de%20pantalla%202024-03-11%20154419-247d8859-844d-4ace-8de6-809764f2db76.jpg)
```txt ```
Ejercicio: Rosalia: \=BUSCARV(B6;N:P;2;FALSO) Bad Bunny: \=BUSCARV(G6;N:P;3;FALSO) ![](https://static.platzi.com/media/user_upload/image-a52fbe2a-b4e7-4a85-aa6b-3a00d6e7f42d.jpg)
Aqui van mis resultados del ejercicio. ![](https://static.platzi.com/media/user_upload/image-a80983b9-89f3-439d-abf5-5c24c925bf86.jpg) F贸rmula para % de b煤squeda de Rosalia. `=BUSCARV(B6;$I$4:$K$35;2;0)` F贸rmula para % de b煤squeda de Bad Bunny `=BUSCARV(E6;$I$4:$K$35;3;0)`
![](https://static.platzi.com/media/user_upload/image-ca0d7bc1-2989-4e58-9edf-45cf20e82c9b.jpg)
Datos: ![](https://static.platzi.com/media/user_upload/image-82e9c1c1-5a70-4a39-8ee5-de15ac5d7f4d.jpg) Resultados Utilizando tres f贸rmulas: ![](https://static.platzi.com/media/user_upload/image-d6d5423e-683f-4047-a51b-b7e151b463e8.jpg)
Si desean hacer el ejercicio pero ahora con BUSCARH, primero seleccionen la fila a buscar el valor (Rosal铆a o Bad Bunny), as铆 mismo seleccionan la tabla desde la primera fila y luego coloquen el n煤mero de fila donde se encuentra la informaci贸n. Consejo: FIjen tanto la celda de la fila del valor a buscar como tambi茅n la matriz para de esta manera solo cambiar e en cual fila encontrar dicho valor.![](https://static.platzi.com/media/user_upload/Captura%20de%20Pantalla%202024-03-01%20a%20la%28s%29%2020.36.41-1e29bb72-6c0d-4a0f-84c0-0add982bf64f.jpg)![](<Captura de Pantalla 2024-03-01 a la(s) 20.36.41.png>)![]()
![](https://static.platzi.com/media/user_upload/image-1f0c4803-182d-49c4-baeb-209d33756c36.jpg)
Realizado el ejercicio. ![](https://static.platzi.com/media/user_upload/image-18387e52-1116-4a3a-8f52-73c79f2825dd.jpg)
mis resultados ![](https://static.platzi.com/media/user_upload/image-0cc780d7-7825-4653-b538-57f299ba2c3d.jpg)
Que tal, les comparto el ejercicio ![](https://static.platzi.com/media/user_upload/image-1bbeaca5-fe6b-460f-a34e-57ee5512b3fc.jpg)
\=BUSCARH(M2;E1:I6;K3+1;0) Utilic茅 esta formula para que el resultado tambi茅n cambiara en funci贸n del vendedor.

Ahora veo porqu茅 en Per煤 estamos como estamos:

![](

Hola, buenas noches, comparto mi soluci贸n y tambi茅n agregu茅 lo aprendido 馃槑 ![](https://static.platzi.com/media/user_upload/curso%2013%20ecxel-935f364b-4a6a-4788-919d-c492df50fae3.jpg)
Me fue m谩s sencillo resolver este ejercicio :D![](file:///C:/Users/Young%20Irving/Downloads/Platzi/Excel/Excel%20Intermedio/Ejercicio%20BuscarV.jpg)
Hola! No se si lo que dice la profesora al final del video de que "si se cambia el ID del vendedor las ventas del mes se quedan est谩ticas" lo entend铆 mal, pero yo lo logr茅 hacer con esto. Ac谩 les dejo una imagen de las f贸rmulas. ![](https://static.platzi.com/media/user_upload/image-8f0a9d68-2f2d-4a10-a51c-9e46c9ce28b8.jpg)![]()![]()
![](https://static.platzi.com/media/user_upload/image-c11d1344-2004-4e3d-bfea-25f5ea33178d.jpg)
![](https://static.platzi.com/media/user_upload/image-712b635f-c546-40ee-83b9-9a469ad74ea8.jpg)
![](https://static.platzi.com/media/user_upload/image-80e9994b-589b-46a1-8b3e-fa13457ea21d.jpg)
![](https://static.platzi.com/media/user_upload/image-e8b82ac7-3dfd-4876-bdad-23c3308017a5.jpg)

Todo el ejercicio aplique el Buscar V, que a opinion personal se me hace mas facil de entender y de automatizar, ejercicio logrado

![](https://static.platzi.com/media/user_upload/image-43ca0ded-4472-458b-9d39-b371ce155cf2.jpg)
Aqu铆 mis respuestas: ![](https://static.platzi.com/media/user_upload/image-fc07a6fb-34bb-45e9-b753-1037ab0c2f13.jpg)![](https://static.platzi.com/media/user_upload/image-26ac9d29-28f3-4cf7-acc4-771ce07b936c.jpg) Muchas gracias
![](https://static.platzi.com/media/user_upload/image-95818482-917f-453a-859f-d1676e8f3e67.jpg)
![](https://static.platzi.com/media/user_upload/image-e090a899-1664-421c-a14a-09746e878959.jpg)
![](https://static.platzi.com/media/user_upload/image-5055b0f2-867e-4c6b-bf69-d6f3071368c2.jpg)![]()
![](https://static.platzi.com/media/user_upload/image-a6ca9ec5-ebb1-49ed-b14d-5c8ace196aa5.jpg) ![](https://static.platzi.com/media/user_upload/image-2634ca6a-ee21-41a4-9790-a554a1b031a4.jpg) La funci贸n de buscarv es la que m谩s uso en mi trabajo y es bueno tener conocimiento de ella para poder gestionar grandes bases de datos.
![](https://static.platzi.com/media/user_upload/image-d6d3835b-8053-48b5-ae1e-6294c8041c8a.jpg)

Sobre el problema que indico la profe Ana al ultimo yo logre resolverlo solo sumandole 1 al valor de ID para que solamente al poner el id me muestre el nombre y de ese modo si deseo cambio el mes y me da los valores correctos.

=BUSCARH(S2;D1:H6;Q3+1;0)

Siempre he usado el BuscarV pero nunca supe que pod铆as poner 0 en vez de falso. Este ha sido un momento revelador en mi vida excel-iana
![](https://static.platzi.com/media/user_upload/image-0e5b5e74-0c32-44a1-8138-b3ea86e40eba.jpg)![](https://static.platzi.com/media/user_upload/image-36378fc0-bdde-424b-a9e5-3b064b42bb2c.jpg)
![](https://static.platzi.com/media/user_upload/image-e1643525-b17b-43c3-bed2-8d49e3a12bd2.jpg)
Respuesta ejercicio: ![]()![](ejercicio)![]()![](https://static.platzi.com/media/user_upload/image-1087b7e4-3987-44da-be8a-eddac1eb3655.jpg)
![](https://static.platzi.com/media/user_upload/Grafico%20Platzi-aa69bcd0-7e6e-4635-8971-789c165b0312.jpg)
![](https://static.platzi.com/media/user_upload/image-4750530d-79eb-415d-8545-ec69d9a0a747.jpg)

Uso de BUSCARV:

Ejercicio ![](https://static.platzi.com/media/user_upload/image-8056bb55-544b-49f2-a91c-2ad5bb553e66.jpg)
Comparto mi solucion amigos, el primer intento que tuve no se por que por alguna razon estaba a intentando colocar "Rosalia o Bad Bunny" en el criterio de valor buscado pero se debe colocar la celda del pais que vamos a buscar :) ![](https://static.platzi.com/media/user_upload/image-dddfdebc-038c-4087-8b2b-65df965ac303.jpg)
![](https://static.platzi.com/media/user_upload/image-55ea3dc7-a42b-4dae-a3d2-05fe0c860ea1.jpg)
Me encanta, me gusta maneja los gr谩ficos dinamicos para todo, es muy util. ![](https://static.platzi.com/media/user_upload/image-a66cb5c8-ab04-4147-a2d3-f8ada6e9ef7d.jpg)
![]()![](file:///C:/Users/aldap/OneDrive/Documentos/Data%20Analyst/Platzy%20BI/Excel/Captura%20de%20pantalla%202023-10-06%20172530.png)![]()![](file:///C:/Users/aldap/OneDrive/Documentos/Data%20Analyst/Platzy%20BI/Excel/Captura%20de%20pantalla%202023-10-06%20172530.png)

Buena pr谩ctica, y de lo que mas se usa.

La versi贸n de Excel que tengo, no aparece como BuscarV, en este caso su equivalente es ConsultaV ![](https://static.platzi.com/media/user_upload/ejerciciobuscarv-ab8e893b-d2fd-42a1-aed5-7c017bc270a4.jpg)

Inserte un gr谩fico para representar visualmente la informaci贸n reflejada

![](https://static.platzi.com/media/user_upload/image-d9b86de4-d9a9-4a6c-a314-50b2c333faf0.jpg)```js ```
```js ```![](https://static.platzi.com/media/user_upload/image-c6adcd3c-898b-4bf7-b055-5b9e12b7b944.jpg)

Yo us茅 =XLOOKUP(DatoABuscar,DondeBuscar,DatoAMostrar) me ayud贸 de forma mil veces m谩s r谩pida

Una peque帽a guia como cambiar el separador de argumentos en las f贸rmulas:

En mi proceso de trabajo yo utilizo la opci贸n buscarx permite buscar sin limite.

Buenas tardes, dejo mis ejercicios.

mi aporte:

para que se actualice de acuerdo al mes, solo le sume +1 a la celda que usamos para buscar el nombre y listo!!!

Les comparto mi versi贸n del ejercicio

Muy 煤til estas funciones.
mi grafico quedo as铆

Buen d铆a,
Adjunto mi respuesta

% de b煤squedas Rosal铆a

Venezuela
=VLOOKUP(B6,I4:K35,2,0)
Chile
=VLOOKUP(B7,I4:K35,2,0)
Colombia
=VLOOKUP(B8,I4:K35,2,0)

=BUSCARV(B6;I4:K35;2;FALSO)
=BUSCARV(E6;I4:K35;3;)

Dado que no me aparec铆a el ejecicio descargable: