No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

F贸rmulas anidadas

14/22
Recursos

Aportes 141

Preguntas 10

Ordenar por:

驴Quieres ver m谩s aportes, preguntas y respuestas de la comunidad?

Bueno, mi soluci贸n a los 2 铆tems del ejercicio fue:

  1. =BUSCARV(F7;F4:J13;2;FALSO)+BUSCARV(F7;F4:J13;3;FALSO)
    Answer = 74%

  2. =CONTAR. SI(J4:J13;"<=5%")
    Answer = 3

A mi me fueron de extrema utilidad para determinar la vigencia de calibraci贸n de instrumentos de medici贸n en un inventario, igualmente las complemente con formatos condicionales.

He visto que se complican de m谩s en algunas respuestas. Yo lo aplicar铆a asi:

Hay varias opciones para solucionar el punto 1, aqui tengo algunas

EJERCICIO DE CONDICIONALES + EXTRA

Compa帽eros!
En esta clase me di cuenta de que me parece importante entender el enunciado de la funci贸n a formular. Les comparto mis apuntes por si de pronto a alguno le sirve!

![](

![](

ah铆 humildemente jajaja

驴Qu茅 son las funciones anidadas? Es una funci贸n dentro de otra para obtener un resultado. Esto que puede parecer realmente complejo, se resuelve de una manera sencilla gracias al uso de las聽funciones anidadas de Excel, lo cual nos permite utilizar una funci贸n como argumento de otra.

A煤n no aparece ning煤n archivo para practicar

Si esto es un curso de nivel intermedio no me quiero imaginar el enemigo final jaja

los resultados para las condicionales, encontr茅 dos resultados para el primer punto

Porcentaje de b煤squedas de Netflix y HBO de Per煤:

N煤mero de pa铆ses con b煤squedas de Amaz贸n Prime de 5% o menos:

Ac谩 dejo mi aporte tratando de aplicar todo lo que vimos en clase, cambie un poco el ejercicio donde el usuario debe elegir el pa铆s y la plataforma que quiere buscar usando listas desplegables . Despu茅s puede elegir por pa铆s y le mostrara un grafico din谩mico.

La formula anidada que utilic茅 para la celda C8 fue est谩: =IF(C6=I4,VLOOKUP(C5,H4:L13,2,0),IF(C6=J4,VLOOKUP(C5,H4:L13,3,0),IF(C6=K4,VLOOKUP(C5,H4:L13,4,0),IF(C6=L4,VLOOKUP(C5,H4:L13,5,0)))))

El mismo ejercicio de la clase pasada, lo resolv铆 de la misma manera.
1.=+VLOOKUP(H7;$H$4:$I$13;2;0)+VLOOKUP(H7;$H$4:$J$13;3;0)
2:=+COUNTIF(L4:L13;"<=5%")

Maravilloso ejercicio. Te hace practicar.

Originalmente solo se aceptaban hasta 8 funciones anidadas pero a partir de Excel 2010, es posible anidar hasta 64 funciones SI. Aunque actualmente el m谩ximo es de 64 funciones anidadas, no llegar谩s ni a la mitad de ese l铆mite cuando comenzar谩s a tener dificultad en entender la l贸gica empleada.

Hola! Les dejo mis resultados. Lo que hice de esta manera, dejando al lado los datos exactos que quiero hallar y luego en la f贸rmula los llam茅. As铆 evito que se fuera por ejemplo Per煤 sin tilde o alg煤n detalle de forma :) ![](https://static.platzi.com/media/user_upload/image-3f1efce5-d8c8-44ff-b4aa-56d00f4ae4a8.jpg)
Mi solucion haciendo uso de XLOOKUP fue \=XLOOKUP(A12,N4:N12,P4:Q12), Lo cual me da dos resultados los de HBO y Netflix, ocupandome dos celdas para dos diferentes resultados respcetivamente. Entonces loa dividi mediante un SI=IF, de esta manera, \=IF(B7=XLOOKUP(A12,N4:N12,O4:O12),SUM(XLOOKUP(A12,N4:N12,P4:P12)+XLOOKUP(A12,N4:N12,Q4:Q12)),"Error") Y el contar es un COUNTIF De esta manera tomando como rango los valores de Amazon Prime \=COUNTIF(S4:S12,"<=5%")
#### **Casos pr谩cticos f贸rmulas anidadas:** 1. **Operadores l贸gicos en f贸rmulas anidadas** * Podemos utilizar operadores como "y" u "o" para aplicar distintas condiciones en una f贸rmula. * Por ejemplo, podemos buscar el total de ventas de enero de 2022 con la f贸rmula: SI(O(A2=1,B2=2022),C2,"Error"). * Tambi茅n podemos utilizar el operador "y" para que se cumplan ambas condiciones: SI(Y(A2=1,B2=2022),C2,"Error"). 2. **Operaciones aritm茅ticas anidadas** * Adem谩s de operadores l贸gicos, podemos incluir operaciones aritm茅ticas dentro de nuestras f贸rmulas anidadas. * Por ejemplo, podemos calcular la suma de ventas de las tres tiendas si el a帽o es 2022, de esta manera: SI(B2=2022,SUMA(D2:F2),0)-C2. 3. **F贸rmulas condicionales anidadas** * Tambi茅n podemos anidar f贸rmulas condicionales dentro de otras para aplicar m煤ltiples criterios. Por ejemplo, podemos determinar si las ventas de un mes son exitosas o bajas seg煤n su monto y el a帽o: SI(B2=2022,SI(C2>120000,"Ventas exitosas","Mes de ventas bajas"),"Ventas de otro a帽o").

Pregunta si es la misma formula por que son diferentes resultados?

En mi caso tengo una modificaci贸n para la primera pregunta en base al comentario de Joel Sierra.

=SI(BUSCARV(鈥淧er煤鈥;H4:L13;1;0)=鈥淧er煤鈥;SUMA(BUSCARV(鈥淧er煤鈥;H4:L13;2;0)+BUSCARV(鈥淧er煤鈥;H4:L13;3;0));鈥淓rror鈥)

Para el ejercicio es bueno para pensar diferente.

Mi soluci贸n es la siguiente:
1.

="Netflix: "&TEXTO(BUSCARV("Per煤";H4:L13;2;0);"0%")&" y HBO: "&TEXTO(BUSCARV("Per煤";H4:L13;3;0);"0%")

Resultado: Netflix: 63% y HBO: 11%
2.

=CONTAR.SI(L5:L13;"<=5%")

Resultado: 3

![](https://static.platzi.com/media/user_upload/image-66860710-ee75-4201-8662-52d56b724829.jpg) Mis formulas para obtener estos resultados fueron la forma mas dificil que encontre para hacerlas jajaja: La Primera: \=("Netflix "&(BUSCARH("Netflix";$G$4:$K$13;4;0)\*100)&"% y HBO "\&BUSCARH("HBO";$G$4:$K$13;4;0)\*100)&"%" La Segunda si es facil: \=CONTAR.SI(K5:K13;"<6%")

Utilize tanto la formula 鈥Si鈥, como la de 鈥BuscarV鈥 y 鈥ContarSI鈥, pero en lo personal se me hizo mejor el BuscarV y el contarSI.

La formula que utilize para el BuscarV: =BUSCARV($B$8,$H$4:$L$13,2,FALSO)+BUSCARV($B$8,$H$4:$L$13,3,FALSO)
La formula que utilize para el Si: =SI(Y(B8=鈥淧er煤鈥,I4=鈥淣etflix鈥,J4=鈥淗BO鈥),SUMA(I7:J7),鈥淓rror鈥)
La formula que utilize para el ContarSi: =CONTARSI(L5:L13,B9)

<3
Buenos d铆as ![](https://static.platzi.com/media/user_upload/image-ecb10c8b-8c13-4cf3-ad00-2f09bfbae583.jpg) ![](https://static.platzi.com/media/user_upload/image-ecf376b8-e9fe-4ba6-bf63-9682f776a01e.jpg)
Dejo esto como soluci贸n a la pregunta 1 del ejercicio. \=SUMA(BUSCARV("Per煤";C11:G20;2;FALSO);BUSCARV("Per煤";C11:G20;3;FALSO))
![](https://static.platzi.com/media/user_upload/image-6af95a5a-c866-43bf-9e5e-813c52734c39.jpg)![](https://static.platzi.com/media/user_upload/image-585a454b-1e2d-46f2-9ab6-9a4fa7ff7a0c.jpg)
Compa帽eros les comparto mis formulas : \=CONCATENAR("Netflix ",TEXTO(BUSCARV($B$12,H4:L13,2,0),"0%"),", HBO ",TEXTO(BUSCARV($B$12,H4:L13,3,0),"0%"),", TOTAL ",TEXTO(BUSCARV($B$12,H4:L13,2,0)+BUSCARV($B$12,H4:L13,3,0),"0%")) Resultado = Netflix 63%, HBO 11%, TOTAL 74% Nota: Asigne la celda B12 como referencia absoluta para buscar los porcentajes de cualquie pa铆s de la tabla *= CONTAR. SI(J4:J13;"<=5%")* Resultado =3
Ya resolv铆 anteriormente especificando detalles: ![](https://static.platzi.com/media/user_upload/image-d00cb75b-bbbf-4e59-b02c-26a04c0bcebf.jpg)
![](https://static.platzi.com/media/user_upload/image-568700f6-13e0-4a6d-b7b9-f0152a480f9f.jpg)![](https://static.platzi.com/media/user_upload/image-0c0596d6-79cf-44cd-a3f1-66c3d60aeaba.jpg)
A modo de aporte, me gustar铆a que se dieran ejemplos m谩s aterrizados cuando explicas las formulas. En algunos ejercicios no tiene sentido las b煤squedas que planteas. Hay una oportunidad de mejora all铆.
![](https://static.platzi.com/media/user_upload/image-ab6b99e1-4905-4854-961a-c77eee136651.jpg)

Mi ejercicio.

Wow esta estuvo dif铆cil 馃槄 ![](https://static.platzi.com/media/user_upload/ecxel%20curso%2014-8e40cdd0-c697-4ac4-9a93-adb3bb03858d.jpg)
Dejo el ejercicio ya que al parecer no me carga bien las im谩genes cuando las pego :( ![]()
![](https://static.platzi.com/media/user_upload/image-101adb88-ef48-4eb8-bed5-1cf2e577f446.jpg)
Hola, con validaci贸n de datos para las f贸rmulas mis respuesta es la siguiente: Para el pa铆s: ![](https://static.platzi.com/media/user_upload/image-5d3e414f-33d4-4b23-914a-76e1984aedb5.jpg) ![](https://static.platzi.com/media/user_upload/image-093ffb7e-e0fb-433d-99c2-acc1850b47c9.jpg) Para variar el porcentaje: ![](https://static.platzi.com/media/user_upload/image-fa0fb268-8e74-4f05-b932-c952c4c353f8.jpg) ![](https://static.platzi.com/media/user_upload/image-406f6048-f9e2-4561-8cfd-8cece8f0e7d7.jpg) En las celdas C8 y C9 se hacen validaciones de datos en formato lista (Alt + A + V + V - Ingl茅s). Previamente se crean nombres para las listas. ![](https://static.platzi.com/media/user_upload/image-c096853f-4f3d-471c-a4b3-af1a675f77d2.jpg) Muchas gracias.
![](https://static.platzi.com/media/user_upload/image-8e6134ef-fc9e-4847-8502-d27a8111998d.jpg)

Muy parecido a la logica de programacion, por lo que veo

![]()Respuesta ejercicio de condicionales:![](https://static.platzi.com/media/user_upload/RTA%20EJERICICIO%20%20CONDICIONALES-40945ffb-c250-443c-a81b-d204ab3bd3a5.jpg)
Hola, esta es mi soluci贸n, ![](https://static.platzi.com/media/user_upload/image-405c0d8a-95b6-4ee1-acb0-dfa8390891c4.jpg) He dejado una celda adicional para cambiar el pa铆s y no tener que modificar la form煤la, Saludos

Condicional:

Muchas gracias por su aportaciones, me ayudas much铆simo.
EJERCICIO ![](https://static.platzi.com/media/user_upload/image-38b67bfe-0e20-4f50-9591-0ee08e281a69.jpg)

Aqui dejo las formulas

da como resultado valor falso si la prueba l贸gica no coincide y da el resultado verdadero si coincide la prueba l贸gica.

=si(Prueba_logica,[valor_si_verdadero].[valor_si_falso]

ejemplo:

=SI(O(A2=1,A2=2),C2,鈥淓rror鈥)

ejemplo de suma

=SI(B2=2022,SI(C2>120000,鈥淰entas exitosas鈥,鈥淢es de ventas bajas鈥)鈥淰entas de otro a帽o鈥)

Comparto mi solucion amigos :3 ![](https://static.platzi.com/media/user_upload/image-15a6042a-08d1-42f6-b7aa-6043a7e9e868.jpg)
tengo un problema, al usar el condicional SI(a2=peru;c2;"falso" me manda error, pero si uso un numero funciona correctamente, no se si tengo algo inhabilitado en mi excell.. lo logre solucionar usando buscarV 3 veces, para obtener el resultado ![](file:///C:/Users/olive/Pictures/Screenshots/Captura%20de%20pantalla%202023-10-27%20114545.png)![](https://static.platzi.com/media/user_upload/Captura%20de%20pantalla%202023-10-27%20114545-82ecd758-f4bc-4053-8c5c-818c6337e088.jpg)

El ejercicio es el mismo de la clase de BuscarV y BuscarH

Para ponerle un poco de reto y complicarme un poco la vida aqui les comparto mi aportacion de una de las 1,001 formas de obtener el resultado del primer ejercicio; a final de cuentas me salio la formula anidada de la formula anidada de la formula anidada 馃ぃ

=SUM(INDEX(F4:J13,MATCH(RIGHT(B5,4),F4:F13,0),MATCH(MID(B5,28,7),F4:J4,0)),INDEX(F4:J13,MATCH(RIGHT(B5,4),F4:F13,0),MATCH(MID(B5,38,3),F4:J4,0)))

me llevo un rartito hacerlo pero se obtuvo el mismo resultado

el segundo ejercicio ya lo hice sencillo porque se me seco el cerebro 馃槣

=COUNTIF(J5:J13,"<=5%")

Animo!!!

Colocando en pr谩ctica lo de la clase y anteriores sin valores quemados:

  1. =SUM(VLOOKUP(H7,H4:L13,2,FALSE),VLOOKUP(H7,H4:L13,3,FALSE)) = 74%
  2. =COUNTIF(L:L,"<=0.05") = 3
1. Resultado fue 74% usando: Si(H7="Per煤";SUMA(I7;J7);"no es Peru") 2. Resultado fue 3 usando:=CONTAR.SI(L5:L13;",=5%")

Lo hice de otra manera, sin el Si, solamente para contar los menores a 5%, Entonces Escribes solamente el nombre del pa铆s y te da la suma del porcentaje de Netflix y HBO

Y ver que esta misma condici贸n se utiliza igual en programaci贸n

A los que no les aparecen los archivos en la computadora... Yo me estoy descargando de la aplicaci贸n celular, all铆 si se pueden ver. Yo prefiero seguir el curso en la PC as铆 que tengo que traerlos del celular.
![](https://static.platzi.com/media/user_upload/image-7c3be602-0a6a-456d-a990-518ba92d7aed.jpg) Yo me apoy茅 con una celda adicional donde poner el Pa铆s que quiero buscar, se facilita mucho y la respuesta la obtengo en dos casillas separadas, es muy f谩cil as铆, no se si lo he hecho bien. En la seguda con CONTARSI

Utilice una tabla din谩mica y seg煤n la informaci贸n calcular谩 autom谩ticamente la informaci贸n requerida.

Mi soluci贸n:

=XLOOKUP(H7,H5:H13,I5:I13)
=XLOOKUP(H7,H5:H13,J5:J7)
=COUNTIF(L5:L13,"<=5%")

Traducci贸n

XLOOKUP = BUSCARX
COUNTIF = CONTAR.SI

Explicaci贸n:

=XLOOKUP("Per煤",Rango de pa铆ses,Rango de Netflix)
=XLOOKUP("Per煤",Rango de pa铆ses,Rango de HBO)
=COUNTIF(Rango de Amazon Prime,"<=5%")
Hola, donde conseguimos los recursos en esta nueva UI ????

La soluci贸n es esta

Un poco dif铆cil pero nada imposible

Lo realice de la siguiente manera

=SI(F7=鈥淧er煤鈥; SUMA(G7;H7);鈥淧a铆s diferente鈥)

=CONTAR.SI.CONJUNTO(J5:J13;"<=5%")

Buen d铆a,

adjunto mi respuesta

Formulas en Ingl茅s
1st

  • =IF(OR(A2=1,A2=2),C2,鈥淓rror鈥)
    2nd

  • =IF(AND(A2=1,B2=2022),C2,鈥淓rror鈥)
    3rd

  • =IF(B2=2022,SUM(D2:F2),0)
    4th

  • =IF(B2=2022,IF(C2>120000,鈥淪ales Achieve鈥,鈥淏ad Month Sales鈥),鈥淪ales from another year鈥)

Solution

  • =VLOOKUP(H7,Table,2,FALSE)+VLOOKUP(H7,Table,3,FALSE)

  • =COUNTIF(Table,"<=5%")

Mi respuesta al ejercicio

=BUSCARV(鈥淧er煤鈥,trends,2,)+BUSCARV(鈥淧er煤鈥,trends,3,FALSO)

En mi caso, las formulas del ejercicio quedaron de la siguiente forma:

=CONTAR.SI(L5:L13,"<=0.05")

=BUSCARV(H7,H5:L13,2,FALSO)+BUSCARV(H7,H5:L13,3,FALSO).

Durante el ejercici贸 me percat茅 de un fallo que estaba cometiendo en la formula CONTAR鈥I , y es que los operadores 鈥<,>,=鈥 no se pueden colocar de forma arbitraria en la formula, siempre deben ir los simbolos 鈥渕ayor que鈥, 鈥渕enor que鈥 en primer lugar y por ultimo el signo de 鈥渋gual鈥. En mi caso, trat茅 de escribirlos en orden inverso y la formula entregaba un valor erroneo.

Espero que les sea de utilidad mi experiencia compa帽eros.

El primer reto lo hice de esta forma!:

SI(H7=H7,I7+J7,"error")

El segundo reto lo hice de esta forma!:

=contar.si(paises,"<=5%")

En mi caso, estas f贸rmulas me sirven para an谩lisis de requerimientos por analista y el estado en el cu谩l se encuentran estas solicitudes.

Hola a todos,
era el mismo ejercicio del archivo de ejercicios-formulas-condicionales. 馃槂 En este caso utilic茅 dos BUSCARV dentro de una SUMA.

Utilic茅 varias maneras aplicando los diferentes talleres anteriores.

se me quemo el cerebro con esta clase, tendre que verla otra vez caballero.

Buena clase.

realizado:

Se me ocurrio hacerlo de manera que responda textualmente la primera pregunta, esta divertido

Mis dos soluciones:

  1. =BUSCARV(D5;H5:L13;2;FALSO)+BUSCARV(D5;H5:L13;3;FALSO) Siendo D5=Pa铆s
    Respuesta: 74%

  2. =CONTAR. SI(L5:L13;"<=0,05")
    Respuesta: 3

Me costo enter mucho esto, pero la informaci贸n es muy clara
(o) es si se cumple al menos un criterio (y) es si se cumple todos los criterios.

Ah铆 vamos!
![](