Do you want to switch to Platzi in English?
0

Pip en Ubuntu

Juan Eduardo
Jotae
2248

Saludos compañeros de platzi!

Hoy les comparto una solución a un problema que he estado teniendo desarrollando en Ubuntu, actualmente estoy escribiendo en VScode, lo que ocurre es que a pesar de haber instalado pip vscode cada vez que lo abría me arrojaba el mensaje de

“Linter pylint is not installed”

Me daba las opciones de instalarlo, o deshabilitar lo, al darle instalar me arrojaba el error de que pip no se encontraba en el ambiente de desarrollo.

Investigando, me di cuenta que pip solo se encontraba instalado para python2.7, busque para corregirlo y vi que para obtener pip en la versión python3.6 se debe ejecutar el siguiente comando

$sudo apt-get install python3-pip

ya con esto se instalara pip en python3 y para ejecutarlo se sigue escribiendo como de costumbre solo que ahora se le agrega un ‘3’ al pip. Ejemplo:

$pip3 install flask

Espero le sirva a alguien de la comunidad.
Saludos

Escribe tu comentario
+ 2