3

¿Problemas con webpack-dev-server ?

¿PROBLEMAS CON WEBPACK DEV SERVER?


Hola, si tienes problemas con la configuracion de la ultima versión de webpack-dev-server 4.0.0

Para usar Webpack dev server se necesitan ciertas versiones de algunas dependencias.

webpack-dev-server v4.0.0+ requires node >= v12.13.0, webpack >= v4.37.0 (but we recommend using webpack >= v5.0.0), and webpack-cli >= v4.7.0.

Extraido de: webpack-dev-server

Mi solución fué seguir los pasos de intalación de la ultima versión de node para WSL: Node


Ya con esto se configura webpack dev server asi:

devServer: {
    static: {
      directory: path.join(__dirname, 'public'),
    },
    compress: true,
    port: 3006
  },

Y en el package.json el script quedó:

"start": "webpack serve --mode development",
Escribe tu comentario
+ 2