Hola, Apple

1

Hablemos de iOS

2

Conozcamos XCode

3

驴Necesito un iPhone para ser iOS Developer?

Tu primera app en iOS

4

隆Hola, Mundo Apple!

5

Navegaci贸n con UINavigationController

6

Modales en la navegaci贸n

7

Utilizando controles en c贸digo

8

Autolayout vs SwiftUI

9

Autolayout

10

Listas con UITableView

11

Celdas personalizadas para nuestras listas.

12

Persistencia: UserDefaults

Manejo de dependencias

13

CocoaPods

14

Carthage

Servicios Web

15

Primeros pasos para consumir servicios

16

Afinando detalles para consumir servicios

17

Convirtiendo los JSON a modelos

18

Alamofire

Proyecto: PlatziTweets

19

Bienvenido a PlatziTweets

20

Configurando Proyecto

21

Dise帽ando vistas iniciales

22

Configuraci贸n de vistas iniciales

23

Configuraci贸n de registro

24

Descripci贸n de la API de PlatziTweets

25

Conexi贸n de la API y Autenticaci贸n

26

Registro de usuarios

27

Dise帽o del Tweet

28

Obteniendo Tweets

29

Creaci贸n de vista para publicar Tweets

30

Publicando Tweets

31

Borrando Tweets

32

Integraci贸n de la c谩mara

33

Conexi贸n con Firebase

34

Configuraci贸n de XCode para correr app

35

Subir imagen a Firebase

36

Publicar Tweet con imagen

37

Tomando Videos para el Tweet

38

Publicar Tweet con video

39

Detalles del video

40

Accediendo al GPS

41

Implementando mapas con MapsKit

42

Mostrando todos los estudiantes en el mapa

43

Retos del proyecto

En producci贸n

44

Enviar a pruebas con Firebase Distribution

45

Enviar tu aplicaci贸n a APP Store Connect

46

Distribuci贸n de tu app con TestFlight

iOS Avanzado

47

Dark Mode

48

SwiftUI

49

Terminando detalles de una vista con SwiftUI

50

Objective-C

Hola, iOS Developer

51

Felicidades

52

Expert Session: 隆nuevo espacio para resolver tus dudas sobre el desarrollo de Apps para iOS!

No tienes acceso a esta clase

隆Contin煤a aprendiendo! 脷nete y comienza a potenciar tu carrera

Configurando Proyecto

20/52
Recursos

Pods que puedes instalar en el proyecto

pod 'NotificationBannerSwift', '~> 3.0.0'
pod 'KeychainSwift'
pod 'SVProgressHUD'
pod 'Simple-Networking', '~> 0.3.2'
pod 'Kingfisher', '~> 5.0'
pod 'Firebase/Storage'
pod 'Firebase/Analytics'
pod 'Fabric'
pod 'Crashlytics'

Aportes 8

Preguntas 3

Ordenar por:

Los aportes, preguntas y respuestas son vitales para aprender en comunidad. Reg铆strate o inicia sesi贸n para participar.

Para la fecha Fabric y Chrashlytic ya est谩n deprecados en su reemplazo utilizar FirebaseCrashlytics

pod 'NotificationBannerSwift', '~> 3.0.0'
  pod 'KeychainSwift'
  pod 'SVProgressHUD'
  pod 'Simple-Networking', '~> 0.3.2'
  pod 'Kingfisher', '~> 5.0'
  pod 'Firebase/Storage'
  pod 'Firebase/Analytics'
  pod 'FirebaseCrashlytics'

Buenas explicaciones!

Por si tampoco les deja copiar de la descripci贸n.

  pod 'NotificationBannerSwift', '~> 3.0.0'
  pod 'KeychainSwift'
  pod 'SVProgressHUD'
  pod 'Simple-Networking', '~> 0.3.2'
  pod 'Kingfisher', '~> 5.0'
  pod 'Firebase/Storage'
  pod 'Firebase/Analytics'
  pod 'Fabric'
  pod 'Crashlytics'

Posibles Soluciones a error de instalacion en M1:
PLUS: Podfile 2022

1.- Duplicate the Terminal application in the Utilities folder.
2.- Right click on the app and choose Get Info.
3.- Rename the other version of the app as you like.
4.- Check the option 鈥渙pen with Rosetta鈥.
5.- Install Cocoapods with the command 鈥渟udo gem install cocoapods鈥
6.- Type the command line 鈥渟udo gem install ffi鈥 to fix the ffi bundle problem.
7.- Now you can do a 鈥減od install鈥 without problem.

# Uncomment the next line to define a global platform for your project
platform :ios, '15.0'

target 'SingleTweet' do
  # Comment the next line if you don't want to use dynamic frameworks
  use_frameworks!

  # Pods for SingleTweet
  pod 'NotificationBannerSwift', '~> 3.0.0'
  pod 'KeychainSwift'
  pod 'SVProgressHUD'
  pod 'Simple-Networking'
  pod 'Kingfisher', '~> 7.0'
  pod 'Firebase/Storage'
  pod 'Firebase/Analytics'
  pod 'FirebaseCrashlytics'

end

Si tienen mensajes de este tipo al compilar despu茅s de generar el proyecto nuevo 鈥淒ouble-quoted include 鈥減b.h鈥 in framework header, expected angle-bracketed instead鈥

Seguir las soluciones de este link

https://stackoverflow.com/questions/63951540/googledatatransport-is-throwing-double-quoted-include-in-framework-header-expect)

Disculpe, donde puedo tener informaci贸n sobre la versi贸n m铆nima del mercado en adelante?, por ejemplo en 2 a帽os ese valor debe ser superior. Gracias por la ayuda

Si alguien tiene problemas con Xcode 12+ o Mac M1 les dejo el siguiente enlace.

IOS 10.3 en adelante para soportar la gran mayoria de Iphones