1

Reparando fechas en Excel.

En lo poco que llevo importando diferentes datos de Kaggle me he dado cuenta que, a la hora de importar un csv, las fechas suelen estar en otro formato, como me pasó acá:
1.PNG

No se que tan común sea este error para otras personas, o si tengo problemas a la hora de importar, en todo caso, creo que puede servir este mini tutorial alguien. 😃

Paso 1
En una hoja aparte, pegamos toda nuestra columna y nos aseguramos de que las fechas estén en el mismo formato.
2.PNG

Paso 2
Creamos columnas para separar mes, día y año.
3.PNG

Paso 3
Hora de sacar las funciones.
Si nuestras fechas estuviesen bien, las funciones de mes, día o año nos servirían, pero vemos que Excel nos muestra el error #¡VALOR!
4.PNG

Para solucionar esto, usaremos una función dentro de una función SI.

=SI.ERROR(MES($B$6);IZQUIERDA($B$6;1))

5.PNG

Ya tenemos los meses, puedes copiar y pegar por toda la columna. 😎🤘
6.PNG

¿Y para aquellos valores que estén en el medio?
Verán que en el ejemplo los días están en medio, pero para eso usaremos la función EXTRAE.

Paso 1
Al igual que en la función para mes, haremos un SI.

=SI.ERROR(DIA(B6);EXTRAE(B6; 3; 2))

7.PNG

Paso 2
Pegar en toda la columna la función. 😄
8.PNG

¿Y para el año?

Paso 1
Usamos la siguiente función.
=SI.ERROR(AÑO(B6);DERECHA(B6; 4))
9.PNG

No olvides copiar y pegar en toda la columna el año. 😉

Para finalizar, unificaremos las fechas en una sola, con la función FECHA.
Nos pedirá en este orden año, mes y día
10.PNG

Terminamos. 😎🤘
11.PNG

Y así tendremos nuestras fechas corregidas con un mismo formato.
Si conoces una mejor solución coméntalo, acepto todo tipo de feedback. 😃
Gracias por ver, espero que te sirva, y nunca pares de aprender! 😎🚀

Escribe tu comentario
+ 2